RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 449 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Turned on 12Z with RF module detached
08-07-2007 12:49 AM  10 years agoPost 1
desertmail

rrNovice

Korea

My Posts: All  Forum  Topic

I accidentally turned on my 12Z without RF module .

Red light blinking , "Module empty" caution where "RF OFF" used to be .

I hastily turned off & attached module .

When I turned on the radio again , "Module Mismatch" this time ...

So I followed the 12Z Calibration steps to set the region of my radio the same as that of my RF module & my 12Z started to work again ...

Now, my 12Z looks back to normal .

But, I still anxious if there would be any damage done to my Radio because of my mistake regarding RF module ...

Does anyone know for certain if my RADIO is completely free of any electrical damage ?

PM  EMAIL  Attn:RR  Quote
08-07-2007 03:08 AM  10 years agoPost 2
JKos

rrProfessor

Redondo Beach, CA

My Posts: All  Forum  Topic

It's perfectly fine to run that radio w/o the RF module. It's perfectly fine to run any radio w/o the RF module.

The problem is running it with the RF module without an antenna for extended time periods.

- John

RR rules!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 449 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Turned on 12Z with RF module detached
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, November 20 - 11:30 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online