RunRyder RC
 4  Topic Subscribe
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 3741 views
Scorpion Power Scorpion Power
Helicopter
e-
Electric Motors-Controllers-ESC
Other › Phoenix HV-85 ESC
03-20-2007 06:15 PM  10 years agoPost 1
eyeflyhelis

rrElite Veteran

charlotte nc

My Posts: All  Forum  Topic

who is using this and what heli do you have it in and whats your programing?
i've got one on the way & want to hear who's doing what. anyone using the gov mode?

only you have the power to make no difference!

PM  EMAIL  GALLERY  Attn:RR
03-20-2007 06:25 PM  10 years agoPost 2
csc

rrApprentice

Cave Creek, AZ

My Posts: All  Forum  Topic

I've got one in my eShuttle. Running a Kontronik Tango 45-08 motor, powered by a Thunder Power TP4600 6SXL lipo battery. Still working on fine tuning the settings but am running in governor "low" mode. Works great.

If you haven't already, check out Clintstone's video on the HV85 setup here...

http://www.heli_freak.com/viewtopic...5517&highlight=
Copy & Paste the link then remove the _ between heli and freak for it to work.

______________________
eShuttles

PM  EMAIL  GALLERY  Attn:RR
03-20-2007 06:50 PM  10 years agoPost 3
HugeOne

rrKey Veteran

Quebec, Canada

My Posts: All  Forum  Topic

I fly mine in an e-raptor 620se on 12S lipo, it's an older version so gov mode don't work well on 12S. I heard the new ones are better.

My setting are:
Voltage cutoff: no cutoff
Cutoff type: slow cutoff
Overcurrent: insensitive
Throttle type: heli fixed end point
Motor start power: 2
Spoolup speed: 3

-Hugo

Raptor e620 w/V-bar, Tango 45-06, Phoenix 85HV, TrueRC 12S1P 4000mAh

PM  EMAIL  GALLERY  Attn:RR
03-20-2007 08:43 PM  10 years agoPost 4
airboss

rrElite Veteran

OC ,california

My Posts: All  Forum  Topic

hv 85

this controller rocks.i have 2 trex 600s both whith hv85s these controllers work well in gov. mode or fixed mode.only negative point is they are fragile,ive sent two back to castle for repair.the heat sink comes off during mild crash.ive talked to castle and they will fix for free.the most they charge for repair is $70.you cant beet that.

PM  EMAIL  GALLERY  Attn:RR
03-21-2007 01:59 AM  10 years agoPost 5
frebou

rrKey Veteran

Montreal / Canada

My Posts: All  Forum  Topic

I have one. It is setuped to run on a mini joker 10S setup with Orbit 30-12 motor.

Only done bench test up to now, still missing some parts to fully assemble the helicopter Should get them in the mail soon...

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
03-31-2007 11:40 AM  10 years agoPost 6
eyeflyhelis

rrElite Veteran

charlotte nc

My Posts: All  Forum  Topic

i got mine in and its bueatiful! i want to make sweet love to it. ok maybe not that nice but damn its STOUT!
ok guys lets get all of your set ups on here
i have the pc interface so scrolling around will be cake work.
anyone find different issues with it yet?

only you have the power to make no difference!

PM  EMAIL  GALLERY  Attn:RR
03-31-2007 01:54 PM  10 years agoPost 7
PG 378

rrNovice

Lufkin, TX

My Posts: All  Forum  Topic

Hv 85

Can't get ours to work right. Works great in fixed end points, but not in gov. We have been on the phone with Castle every day now for over a week. It goes strait to full throttle as soon as we get over 55% on throttle ATV. It is in a Razor ,Hacker A50-14S, 3700batts.

We will keep working.

PM  EMAIL  Attn:RR
03-31-2007 02:01 PM  10 years agoPost 8
eyeflyhelis

rrElite Veteran

charlotte nc

My Posts: All  Forum  Topic

is that in high or low mode?
had a similar problem with my CC35 in high mode. so i switched it to low mode and ran it up to 70% and got the RPM i wanted.
from what i hear the gov mode works excellant on 85.
do you have the pc link?

only you have the power to make no difference!

PM  EMAIL  GALLERY  Attn:RR
03-31-2007 02:03 PM  10 years agoPost 9
eyeflyhelis

rrElite Veteran

charlotte nc

My Posts: All  Forum  Topic

btw in high mode on the 35 im couldn't go over 30%. what rpm are you seeing below 55%?
please list your settings up here maybe i or someone else can help

only you have the power to make no difference!

PM  EMAIL  GALLERY  Attn:RR
03-31-2007 04:07 PM  10 years agoPost 10
frebou

rrKey Veteran

Montreal / Canada

My Posts: All  Forum  Topic

Well... just had my first "real" flight with my CC85hv yesterday and the CC85HV just poped off after 45 seconds...

Don't know what happened, was working great in governor mode, about 1700 rpm on the head and it shutdown and smelled toasted. I won't start the motor anymore now...

I'll check with Castle Creations and see why it did happen...

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
03-31-2007 04:23 PM  10 years agoPost 11
PG 378

rrNovice

Lufkin, TX

My Posts: All  Forum  Topic

Yes, we have the link. In governor low we get almost no head speed at all. Just a few hundred rpms. In governor high, below 55% we will get varying head speeds based upon the percentage. But there is an intermittent blurp, glitch, pulse, cut out, whatever you want to call it. We will get a head speed for second and 1/2 and then a blurp, then head speed for second 1/2 and then another blurp... Anything above 55% it goes to an immediate 2230 head speed and holds fine. No matter what percentage I put in above 55% there is no change in head speed. We have tried the governor gain at medium, at low, and custom all the way down to 16. Nothing affects it. We have tried the timing in high standard at low. Nothing affects it. In fixed endpoints, 75% gives a 1750; 80% gives us 1850; 85% gives us 1950; 90% gives us 2080; 100% gives us 2240.

Hope this help.
We could use some help!

Steve

PM  EMAIL  Attn:RR
03-31-2007 06:11 PM  10 years agoPost 12
eyeflyhelis

rrElite Veteran

charlotte nc

My Posts: All  Forum  Topic

PG 378
i suggest starting all over, reset it to factory settings and then reprogram it in gov high mode. i had one CC that needed to be reset everytime i changed from low to high mode, not sure why. be sure to save reset then re-input your setting for high mode.
personally i can never get over 38% in high mode with out over speeding the head.
if you reset it with no change reset it again and go into low mode and try that and set up once more.
my help is only my experience so it may or may not help you.
dont forget to let us know what you find.

only you have the power to make no difference!

PM  EMAIL  GALLERY  Attn:RR
03-31-2007 06:11 PM  10 years agoPost 13
eyeflyhelis

rrElite Veteran

charlotte nc

My Posts: All  Forum  Topic

frebou 1700 is low head setting. If you had the pitch to high you may have over loaded the speed control or the motor.

Are you sure the motor didn’t fry?
What motor is it? Here is an example of what may have happened. The HV 85 has lower internal resistance than the align ESC. If your align motor was ok to marginal it would work great with the align esc (lower total out put range) the HV 85 would be a higher out put range at ever setting.
Example 100% Align may only be 90% hv85. so 100% HV would be putting a lot more power to the motor, at 1700 rpm if you go for a climbout you could easily have over loaded the motor.
My $.02

only you have the power to make no difference!

PM  EMAIL  GALLERY  Attn:RR
03-31-2007 06:12 PM  10 years agoPost 14
eyeflyhelis

rrElite Veteran

charlotte nc

My Posts: All  Forum  Topic

PG 378 whats your atv end point at? what radio?

only you have the power to make no difference!

PM  EMAIL  GALLERY  Attn:RR
03-31-2007 08:25 PM  10 years agoPost 15
aerton

rrVeteran

Longueuil, QC,​Canada

My Posts: All  Forum  Topic

I have it in Swift 16. I like the fact that it doesn't get hot for my 7S hovering setup. Governor, I tried once, it was similar to what was said, it kind of had 2 position throttle, like 30 % and 100% and it gave me an impression that it was overspeeding. Motor was neu 1910 1.5. So I don't use it in that mode.

It's a bit fragile, I had 1 cube disconnected from the PCB because I put it with heatsink up, PCB facing the heli, so vibration disconnected it. And then when I put it so the capacitors touched a bit the canopy, the capacitor disconnected. I repaired it all myself, and just rolled insulation tape over it. Now it works great. I would say it's a great controller.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
03-31-2007 09:14 PM  10 years agoPost 16
PG 378

rrNovice

Lufkin, TX

My Posts: All  Forum  Topic

We are using a Dx7. Endpoints are Hi 97, low 117.
We did start over...3 times... it's always the same.

PM  EMAIL  Attn:RR
04-01-2007 04:32 AM  10 years agoPost 17
frebou

rrKey Veteran

Montreal / Canada

My Posts: All  Forum  Topic

eyeflyhelis : It was my first flight. The manual says to run it at 75% in fixed point mode (which gave me 1690 rpm) and than, switch to low gov and try to get that same value. In low gov, the max I could get was 1200-1300. So switched to High gov and played with the throttle % until I had about the same value (65% = 1700) I did a nice hover, little circuit and it spooled down.

Landed, the thing smelled burned, not noticing anything I tried to arm again, the motor won't start. Tryed with another ESC and the motor works.

there seems to be something that blown from the ESC because the shrink wrap has been torn apart :

I really don't know what happened...

Motor : Orbit 30-12
using 10S 3700mAh

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
04-01-2007 12:25 PM  10 years agoPost 18
PG 378

rrNovice

Lufkin, TX

My Posts: All  Forum  Topic

We flew again yesterday. This time we just used thro curve of 100-95-100 in Fixed. It would bog a little. Seems to run better at Gov Hi, but I'm afraid we will smoke something also!!

Puzzled,
Steve

PM  EMAIL  Attn:RR
04-01-2007 08:54 PM  10 years agoPost 19
eyeflyhelis

rrElite Veteran

charlotte nc

My Posts: All  Forum  Topic

frebou check your caps arent loose or broken off

only you have the power to make no difference!

PM  EMAIL  GALLERY  Attn:RR
04-01-2007 08:56 PM  10 years agoPost 20
eyeflyhelis

rrElite Veteran

charlotte nc

My Posts: All  Forum  Topic

PG 378 what blades are you running? what pitch?
i hear of a bunch of guys running a 2300ish head speed on the 600 with carbon blades.
i try to get around 2200

only you have the power to make no difference!

PM  EMAIL  GALLERY  Attn:RR
WATCH
 3 pages [ <<    <    ( 1 )     2      3     NEXT    >> ] 3741 views
Scorpion Power Scorpion Power
Helicopter
e-
Electric Motors-Controllers-ESC
Other › Phoenix HV-85 ESC
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Wednesday, November 22 - 6:43 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online