RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 427 views
HelicopterHIROBOOther › anyone having prob. installing hatori sb17 pipe?
01-28-2007 06:42 PM  10 years agoPost 1
saitoflyer

rrVeteran

L.A. CA

My Posts: All  Forum  Topic

i have an evo 90 with 91OSsz and those rubber rings on the pipe, i cant seem to get them inside the pipe barrel.. i tried lubricants like windex to try to slide them but at the end, thr rubber rings get pinched and are not in center.. does anyone else experience this problem?? thanks

is that a new heli? Oh no honey, its the same one w/different stickers.....

PM  EMAIL  GALLERY  Attn:RR  Quote
01-28-2007 07:56 PM  10 years agoPost 2
Leif

rrElite Veteran

USA

My Posts: All  Forum  Topic

When the o-rings are new, it's a b!tch to get the pipe on the first time. The first o-ring goes in OK, but the second one always wants to bulge out on one side. At least this is what I experienced with my SB-50JK.

You just need to work at it and be very careful to push the pipe on straight. Some oil on the pipe and o-rings helps, but the key is to push the pipe on straight. I also found that if it does bulge out, you can pull on the pipe while gently nudging the bulge back into the opening with a popsicle stick.

Once the o-rings get hot, they tend to harden and flatten a bit, so you won't experience this for subsequent installations unless you replace the o-rings.

Leif

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 427 views
HelicopterHIROBOOther › anyone having prob. installing hatori sb17 pipe?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Sunday, December 17 - 12:18 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online