RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 508 views
Helicopter
e-
Electric Motors-Controllers-ESC
Other › CC Phoenix 45HV Problem
01-27-2007 11:39 PM  10 years agoPost 1
breedatrad

rrApprentice

NW PA

My Posts: All  Forum  Topic

I've got a 45HV in a Swift on TP4500's. After spool-up; the throttle starts "jerking", driving the tail nuts. After I shut it down, the ESC blinks 7 times (excess radio noise).
I've got the (PCM) Rx, Batt and Gyro at the back of the heli.

Any suggestions?

Brian

PM  EMAIL  GALLERY  Attn:RR  Quote
01-28-2007 02:10 AM  10 years agoPost 2
Tap or Snap

rrApprentice

Port Richey, Florida and Burlington, Wisconsin

My Posts: All  Forum  Topic

Try an RFI surpression filter such as this:
http://www2.towerhobbies.com/cgi-bi...&I=FUTM4149&P=K

One end plugs into the receiver throttle channel and the other into the speed controller.

If your using Govenor mode make sure the govenor gain isnt set to high. Try using heli-fixed end-points and fly with a throttle curve in normal mode 0,65,95,95,95 and see if goes away. Keeping your electronics away from the motor and controller helps too. This goes for the antenna also. Without actually being there Im only guessing at this point as to things you might try.

Jeff

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 508 views
Helicopter
e-
Electric Motors-Controllers-ESC
Other › CC Phoenix 45HV Problem
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Tuesday, December 12 - 8:29 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online