RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 739 views
Helicopter
e-
Blade
Blade CX › turning right on full batt. and left on low
01-26-2007 01:58 PM  10 years agoPost 1
johndog35

rrApprentice

Kansas City, Kansas

My Posts: All  Forum  Topic

Any body have problem with CX wanting to turn to right on full battery and as the battery gets low it wants to turn to the left. I dont mean a little bit. I mean you have to keep the stick pushed to one side to keep it straight. Im wondering if maybe my 4 n 1 is starting to go bad.

Landings are nothing more than controled crashes

PM  EMAIL  Attn:RR  Quote
01-26-2007 03:41 PM  10 years agoPost 2
mikerino

rrNovice

NH

My Posts: All  Forum  Topic

PM  EMAIL  Attn:RR  Quote
01-26-2007 04:39 PM  10 years agoPost 3
johndog35

rrApprentice

Kansas City, Kansas

My Posts: All  Forum  Topic

I have done all of these things and have the upper and lower aluminum upgrades. Got tired of replacing them every time you bump the blades. Also I have vented to box. Never noticed any change on that part. It was worth a look though.

Landings are nothing more than controled crashes

PM  EMAIL  Attn:RR  Quote
01-26-2007 05:10 PM  10 years agoPost 4
stickyfox

rrKey Veteran

Rochester, NY - US

My Posts: All  Forum  Topic

It's possibly because the ESC is heating up and warming your gyro, causing it to drift. My BCP does this; it's a lot worse when the weather's cold. You probably have to push to the right initially because you set the trim pots with a slightly warmed-up 4/1. If you land periodically and reset the power it will recalibrate. Or you can do as described in the link above, but it doesn't really help much, and there's pretty much nothing you can do if you're flying in a cold garage or auditorium.

-fox

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
01-26-2007 05:20 PM  10 years agoPost 5
johndog35

rrApprentice

Kansas City, Kansas

My Posts: All  Forum  Topic

Another thing is that its killing my battery time. I bought 2 new batteries because flight time is only about 3 minutes and I used to get 6. But this didnt help. This thing just eat my batteries for lunch.

Landings are nothing more than controled crashes

PM  EMAIL  Attn:RR  Quote
01-26-2007 06:14 PM  10 years agoPost 6
stickyfox

rrKey Veteran

Rochester, NY - US

My Posts: All  Forum  Topic

My CX2 really eats batteries too. I figured they were all like that.

-fox

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
01-26-2007 07:14 PM  10 years agoPost 7
johndog35

rrApprentice

Kansas City, Kansas

My Posts: All  Forum  Topic

I have the CX 1 so to speak. I got it from a bad trade and it was modified by the previos owner. Never was right. Throttle has always be very twitchy.

Landings are nothing more than controled crashes

PM  EMAIL  Attn:RR  Quote
02-12-2007 09:43 PM  10 years agoPost 8
Leader

rrNovice

Finland

My Posts: All  Forum  Topic

I have CX 2 with the same behavior. Is this happening to all of you CX and CX 2 guys?



there are no wrong settings.. only different ones..

PM  EMAIL  Attn:RR  Quote
02-12-2007 11:17 PM  10 years agoPost 9
doccopter

rrNovice

Staten Island, NY

My Posts: All  Forum  Topic

Battery times

I have a CX2 with no mods. I am getting about 7-8 mins per charge on both batteries. no problem with the heli turning right or left either. It does get a little twitchy as the battery runs down.

PM  EMAIL  Attn:RR  Quote
02-13-2007 02:29 AM  10 years agoPost 10
Lowezz

rrApprentice

Canada

My Posts: All  Forum  Topic

I Have a Lama V3 in my collection. The Lama is similar to the CX, coaxial blades. Mine also turns to the right and left after a minute of flying. It will turn to the left, I'll trim it and after a minute of flying perfect it will start turning to the right. I have to adjust the trim during flight every minute or so. Honestly Iv'e gotten so used to it that it doesn't really bother me anymore. I have no idea why it does it. Maybe the gyro gets a little disoriented! Also make sure you absolutly don't move the heli when turning it on as it is being initialized. The gyro is disoriented if the heli is moved around while in this process. After the solid green light is flashing away she goes!

PM  EMAIL  GALLERY  Attn:RR  Quote
02-13-2007 06:01 AM  10 years agoPost 11
Road King

rrNovice

Goldendale Wa.

My Posts: All  Forum  Topic

I just bought a brand new CX2 & it goes nose left with full batt , then nose right as batt gets low. by the end of batt ( 6-7 ) minuites my trim is all the way over.
I haven't tried the fix (drilling holes) yet because I wanted to see if there is a break in period and things might loosen up a bit because some of the time the tail stays put for a couple of seconds.
I did try the pot adjustment and that helped some but not enough to fly 1 battery without having the trim maxed out by the end of battery.
I am kind of disappointed in my CX2 but I can atleast fly in the house now.
Good post!!

Bob

PM  EMAIL  GALLERY  Attn:RR  Quote
02-13-2007 06:24 AM  10 years agoPost 12
Road King

rrNovice

Goldendale Wa.

My Posts: All  Forum  Topic

Willy
the battery Iam using is the new lipo that came with it.
I purchased another CX2 from a fellow RR member but have not received it yet, I plan to do some serious experimentation (sp) with that one.

Bob

PM  EMAIL  GALLERY  Attn:RR  Quote
02-13-2007 06:31 AM  10 years agoPost 13
Road King

rrNovice

Goldendale Wa.

My Posts: All  Forum  Topic

about 6 to 7 minuites , a couple of other guys I fly with are getting about 10 + min , I haven't measured with the volt meter on this battery because It has left / right issues from the start so I don't believe it is a low voltage problem.

Bob

PM  EMAIL  GALLERY  Attn:RR  Quote
02-13-2007 07:04 AM  10 years agoPost 14
Road King

rrNovice

Goldendale Wa.

My Posts: All  Forum  Topic

I am 99% sure the batt voltage is not too low, but will check it just for grins the next time I spool up the blade . Too many people are having the same issue with tail drift . I am sure someone will sort it out. Got to work in the morn , thanks for your input...

Bob

PM  EMAIL  GALLERY  Attn:RR  Quote
04-21-2007 10:49 AM  10 years agoPost 15
Leader

rrNovice

Finland

My Posts: All  Forum  Topic

Bob,

Mine stops after I unplug my CX 2 heli's power cord and plug it back. That behavior starts again after about 5-7 minutes. Maybe I should drill the 4in1 full of holes to see if it helps.



there are no wrong settings.. only different ones..

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 739 views
Helicopter
e-
Blade
Blade CX › turning right on full batt. and left on low
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Thursday, December 14 - 1:23 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online