RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 354 views
HelicopterEngines Plugs Mufflers Fuel › Deposits on glow plug
01-24-2007 03:09 PM  10 years agoPost 1
Snake Rimmer

rrApprentice

Up north in the England

My Posts: All  Forum  Topic

Today I came to start my Helli with no joy so thought I would check my plug when I took it off the element was covered in what looked like a black crusty substance, yesterday I did notice that my rev's were very much up and down.

Could anyone give me reason as to why this happened, its a OS 37 engine.

To infinity and......................... the ground........... Team Rimmer

PM  EMAIL  GALLERY  Attn:RR  Quote
01-24-2007 03:18 PM  10 years agoPost 2
z11355

rrMaster

New England

My Posts: All  Forum  Topic

you're running the needles slightly too rich.

what fuel?

PM  EMAIL  GALLERY  Attn:RR  Quote
01-24-2007 03:40 PM  10 years agoPost 3
Snake Rimmer

rrApprentice

Up north in the England

My Posts: All  Forum  Topic

What both needeles

To infinity and......................... the ground........... Team Rimmer

PM  EMAIL  GALLERY  Attn:RR  Quote
01-24-2007 03:58 PM  10 years agoPost 4
PaulJC

rrElite Veteran

Hertfordshire UK

My Posts: All  Forum  Topic

What both needeles
Can't really tell from here, hows the transistion

Re-entering the atmosphere...

PM  EMAIL  GALLERY  Attn:RR  Quote
01-24-2007 04:31 PM  10 years agoPost 5
Snake Rimmer

rrApprentice

Up north in the England

My Posts: All  Forum  Topic

Seems to start slow then really gets going and is up and down in flight.

To infinity and......................... the ground........... Team Rimmer

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 354 views
HelicopterEngines Plugs Mufflers Fuel › Deposits on glow plug
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Saturday, December 16 - 8:37 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online