RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 513 views
Helicopter
e-
Blade
Blade CX › 1½?
01-22-2007 07:50 AM  10 years agoPost 1
Digital Don

rrNovice

Chicago, IL U.S.A.

My Posts: All  Forum  Topic

I’ve had a Blade CX2 for about a month. Although I’ve only been able to play around with it in the kitchen, so far it’s been great.

Just recently, I have a opportunity to pick up a used CX - I figured I could use it for practice. As it turns out, it actually flies very nicely. However, I’ve grown quite fond of the new Spektrum radio the CX2 uses, especially the tiny transmitter antenna!

Since I already had the Spektrum transmitter, I wanted to convert the radio system on the CX. In spite of the current Blade CX/2 parts shortage, I was lucky enough to find a CX2 4-in-1 at a local hobby shop!

The conversion is pretty straightforward, but there are a few things to be aware of. First, the size and shape of the CX2’s 4-in-1 is somewhat different than the CX’s, and second, the location of the connections are different so its not a direct fit.

On my particular CX, the left motor lead was barely long enough to reach the correct slot on the receiver. This made it necessary for me to add a spacer between the shelf and the 4-in-1 as described below.

The CX chassis has an “L shaped” shelf for the standard 4-in-1; the CX2’s shelf is flat. I used a Dremel tool to remove the vertical part of the shelf (shown in red in photo 1), because the elevator servo connector would not clear it. Ultimately, I didn’t need to do this because it was necessary to add a spacer to raise the 4-in-1 a little to minimize stress on the lower motor connector (photo 2). The spacer is about 1/8” thick and made of some Kydex I had left over from my R/C car days.

I used CA to attach the spacer to the original shelf. The 4-in-1 is attached to the spacer with servo tape, and I used a couple of zip ties to secure and stabilize the unit (photo 3). Everything just fits under the front fuselage. The finished project can be seen in photo 4.

Incidentally, when I first powered up the receiver, I got the dreaded red/green ‘flash of death’! After binding it to my transmitter though, it worked fine.

With my CX2, I didn’t bind the receiver until after I had performed the control checks specified in the manual, so I figured this shouldn’t be required. However, if the CX2 was ‘test flown at the factory’, I realized it must have been already ‘bound’ when I got it.

Works for me!

Don

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 513 views
Helicopter
e-
Blade
Blade CX › 1½?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Sunday, December 17 - 5:51 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online