RunRyder RC
 5  Topic Subscribe
WATCH
 3 pages [ <<    <     1      2     ( 3 )    >    >> ] 2338 views
01-22-2007 11:41 PM  10 years agoPost 41
jimboflies

rrElite Veteran

Beaumont, Texas;

My Posts: All  Forum  Topic

Here is his web-site http://rclovers.com/WhoWeAre.htm
the Enerland lipo 2 are the 20C

EP8 EX twinring frame
Quick of Japan
EP8v2 EX
EP9

PM  EMAIL  GALLERY  Attn:RR  Quote
01-23-2007 01:49 AM  10 years agoPost 42
gorn

rrElite Veteran

Western Australia

My Posts: All  Forum  Topic

Thanks Jimbo
Thats a pretty huge battery store for Ebay!

For the love of the hobby

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
01-23-2007 02:00 AM  10 years agoPost 43
jimboflies

rrElite Veteran

Beaumont, Texas;

My Posts: All  Forum  Topic

I am very impressed with their batteries, I flew this 4s1p 3700mah 20C for 6 minutes , 2 times so far ; the first time 1726mah put back in ; the second flight 1849 , and the power is way better than my Tanic packs when they were new! The quality is better than anything I have had , construction wise, power wise! $103 for this 4s1p 3700mah 20C, 30C, 40C pack!!You just cant beat that ! And , I ordered it Friday night , and it is here Monday!@! Thats service!

EP8 EX twinring frame
Quick of Japan
EP8v2 EX
EP9

PM  EMAIL  GALLERY  Attn:RR  Quote
02-04-2007 05:47 PM  10 years agoPost 44
gorn

rrElite Veteran

Western Australia

My Posts: All  Forum  Topic

Some pre-maiden pics with the new chassis.
So option parts Ive used are obviously the Rotorworkz SE chassis, K&S 30 size adjustable paddles, and now Im running 6v lipo flight pack powered cyclic servo's, regulated to 5v for the tail servo.
To do that Ive used the Align Trex 600 voltage reg.
That setup with my 1800 2s pack comes in about 50g lighter than using the equivalent NICD pack and voltage display.
The Align unit also has an LED panel to show how the lipo is doing.
Ive yet to see any other LED unit showing pack health for lipo's.
First tests will be done with my usual Flightpower Evo20 3s 2150 packs for 6s.
At the end of the week I will be swapping the stock swash plate for an optional QJ swash that has double bearings, same as the EX swash but with 6mm shaft and is silver.
Without installing it I can feel a huge decrease in slop over the stock unit.
I just want to get a feel for her again before I make the change, so then I can be certain about any fealt flight difference.
After I do that I will swap over to my Mega on 6s and compare to the Hacker for duration and power on 6s.
For power testing Im just going to strap my GPS underneath the heli and record max vertical speed over a measured distance.
Then Im swapping over to my BIG BOY pack lol, and see how she feels on 3s2p for putzing around.
Heres some pics of how she looks now.
You can see the Align voltage reg and the 2s lipo.
Cheers

For the love of the hobby

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-05-2007 07:39 AM  10 years agoPost 45
jimboflies

rrElite Veteran

Beaumont, Texas;

My Posts: All  Forum  Topic

SWEET , looking good gorn!! I went ahead and got the Align voltage reg. also and it works very well.. I took your advice from this post gorn !!!
http://runryder.com/helicopter/t307614p1/

EP8 EX twinring frame
Quick of Japan
EP8v2 EX
EP9

PM  EMAIL  GALLERY  Attn:RR  Quote
02-05-2007 11:28 AM  10 years agoPost 46
contact303

rrVeteran

Netherlands

My Posts: All  Forum  Topic

Beauty that bird
let us know how it goes
I see your ideas with the BEC and 2S lipo but with my jazz i cant see the need
ANy other ESC i'd do the ecxat same . SAFE IS SAFE !
Nice Setup ..6s will be balistic

PM  EMAIL  GALLERY  Attn:RR  Quote
02-05-2007 02:06 PM  10 years agoPost 47
gorn

rrElite Veteran

Western Australia

My Posts: All  Forum  Topic

Thanks guys
I tried pretty hard to hide as much wiring as possible this time, but the damn 401 and 9254 leads are sooooo long!!
Gonna have to get me a servo shortening kit, dont like the idea of cutting them and soldering the leads back together.
I hate big blobs of wiring!

Anyway, so I flew her tonight in the warehouse at work.
Rangecheck was a bit short at about 12 meters, but we are surrounded by steel product and wireless RF units....

She felt very sensitive even with 30% expo, but its got much more cyclic travel now, plus the 6v plus the lighter paddles are back on.
Paddles are mostly for visibility for me, as they stand out like dogs bollocks

Im getting some very minor glitching on cyclic, just a very brief quick right hand twitch every now and then.
No real loss of control, but unnerving.

I also got my tail linkage the wrong length lol (I knew this would happen ) so Ive got a low frequency mild wag going on.
So the glitching, wagging and sensitivity is not making me exude 3d confidence right now lol.

I weighed it tonight......FAT PIGGY!! 1800g
Thats ready to fly with all batteries aboard and glass canopy.
Needs a diet, but really I can only change the canopy and main batteries.

I cant afford new batteries and I like the glass canopy, so FAT she will be lol.
Im thinking this will actually be a plus around here, as we always get a strong afternoon sea breeze.
So weight will help in the stronger winds.

A friend took some video and stills of the QJ in flight tonight, so as soon as he gets that back to me I will post what I can.
Just hovering about getting a feel for it, and sussing out that glitch.

Cheers

For the love of the hobby

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-05-2007 06:38 PM  10 years agoPost 48
contact303

rrVeteran

Netherlands

My Posts: All  Forum  Topic

FAT she is indeed
my stretched kit with 470mm blades and 5s 3200 is 1780gr and i thought i was fat ..

Now for wire salad ..
I had the same problem ...
What i done is orer myself a lot of 5-11mm cable protection for AUDIO equiment :O)
Check this out :

With this you can doubble up thewire and hide it
No nee to cut anything . Cut the wire protection to size e and it stretches to get the plugs through as well . this 5-11mm stretchy nylon stuff is great

PM  EMAIL  GALLERY  Attn:RR  Quote
02-05-2007 09:56 PM  10 years agoPost 49
jimboflies

rrElite Veteran

Beaumont, Texas;

My Posts: All  Forum  Topic

I ended up cutting my gy401 wires , they are just too long!!

EP8 EX twinring frame
Quick of Japan
EP8v2 EX
EP9

PM  EMAIL  GALLERY  Attn:RR  Quote
02-10-2007 02:07 PM  10 years agoPost 50
gorn

rrElite Veteran

Western Australia

My Posts: All  Forum  Topic

Here's a pic of an ugly pilot in GREAT need of a shave and a holiday
Thought Id post it so people can see the scale of an EP8 rather than just asking how it compares to a Trex.
Couple of pics from the maiden as well.
Im going to shorten all the gyro wires ASAP, and the wire to the voltage reg is half a mile long too, so that needs trimming.
I HATE spaghetti wiring!! blechh.
Lucky I pulled the gyro off, as I could smell that bad electrical smell.....
Turns out that somehow the pins to my Y lead were shorting out a bit.
So Ive fixed that, and I also noticed that in my rush to get her airborne, I routed the esc wire right along side the antennae DOH!!
So that could be the source of my little glitches.
Still have to remount the cyclic servo's, as I used the rubber mounting grommets (I did on the old chassis too), but the servo's rock a bit now, and Im not happy with the amount of movement in them.
So I will be taking those off and hard mounting the servo's.
I tached it at zero pitch and 95% throttle, cant remember the exact number, but it was over 2600rpm
Hmmmmmmm, no vibes etc etc.
You can hear the motor load up as soon as pitch is applied, so Im guessing around 2400-2450rpm, which is what I wanted.
I love the sound of that Hacker with the fan, nice whining sound....aaahhhhh
Post some pics of you ugly buggers holding your QJ's!!!!
Matter of fact, I'll start another thread for that

For the love of the hobby

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-10-2007 02:08 PM  10 years agoPost 51
gorn

rrElite Veteran

Western Australia

My Posts: All  Forum  Topic

Fastphoto is really handy and all........but man does the pic quality suffer!
Oh well

For the love of the hobby

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-10-2007 02:52 PM  10 years agoPost 52
jimboflies

rrElite Veteran

Beaumont, Texas;

My Posts: All  Forum  Topic

Here's a pic of an ugly pilot
Man , you aint kidding about that!!! Just kidding!
Glad you got your SE going , I had a problem with glitches on my SE also , I was using a Revolution whip antenna and I changed it back to the original long and that solved my problem..
Now my EP-16V2 is another story, I am plauged with major glitches, I have tried 3 different receivers (PPM-FM)so I can say that it is not an R/X problem..... I guess I have to start rerouting everything...
Okay, here is another ugly EP-8 EX SE Pilot...I think my eyes are closed in this pic

EP8 EX twinring frame
Quick of Japan
EP8v2 EX
EP9

PM  EMAIL  GALLERY  Attn:RR  Quote
02-10-2007 03:03 PM  10 years agoPost 53
gorn

rrElite Veteran

Western Australia

My Posts: All  Forum  Topic

Lol at eyes closed!
Have you got a ferrite ring on your esc wire?
I use one of those and a glitch no more thingy.
Done by http://www.dionysusdesign.com
Now I dunno if this thing helps a great deal, but when installed, Im yet to have a crash due to glitching, and when it does glitch, its just a split second.
Enough to make me jump, but thats all, and its not often.

Strangely Im also using less MaH out of my packs now. Only thing I can think of is that my gear mesh and belt tension is a bit free'er maybe?
Im glad though lol.

Y'know Jimbo, as soon as I saw your pic, I was like "that dude took my heli....and painted the parts blue! " lol
Its the intercontinental "QJ Lemon Society", exclusive too, just you and me, so we must be upper class now.....right? lol
Seeya

For the love of the hobby

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
02-10-2007 05:37 PM  10 years agoPost 54
jimboflies

rrElite Veteran

Beaumont, Texas;

My Posts: All  Forum  Topic

Yup , I saw your canopy a long time ago and I did mine YELLOW also , and it just kinda stuck in my head , and it is very easy to see in flight...
I have never tried a ferrite ring so I guess I need to get me one and try it.. You know I was looking at my belt and it looked dry , so I thought static electricity from the belt , so , I took a rag and soaked it with a little motor oil (10w40 Pennsoil)and I just wiped the belt as I turned the gears; I have flown it around my yard 2 times with NO glitching ,NONE, could that have caused my glitches????? Maybe??? I am charging a set of batteries to try it again , so if it does not glitch that must have been the problem, we will see!!!

EP8 EX twinring frame
Quick of Japan
EP8v2 EX
EP9

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 3 pages [ <<    <     1      2     ( 3 )    >    >> ] 2338 views
 Print TOPIC  Make Suggestion 

 5  Topic Subscribe

Thursday, December 14 - 6:44 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online