RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 843 views POST REPLY
Helicopter
e-
Blade
Other › HI What Do you GUYs think of my new Body Set Up!!>??
11-24-2006 06:07 AM  11 years agoPost 1
BLADE CP GUY

rrApprentice

Houston, Texas- USA

My Posts: All  Forum  Topic

HI..IT's me the Blade CP Guy...I'm Finally upgrading for a full "body armor" for my blade cp...I just ordered some upgrade parts from HELIDIRECT.COM. And these is what I bought...SUPER_LANDING SKIDS, PLASTI BLADES, after market MAin Shaft and Gear Whay do you Guys think????? and for my UTH(UNDER THE HOOD) is a LIpo battery 910 mamph and a 9 pinion T motor...IF you guys think the weight would be a problem dont worry ...I am also about to get a BRushless system...I just need some money and time to get it..But what I need is you opinions about these parts...

HEre's exactly what I ordered
[url=http://www.helidirect.com/shopping_cart.php]

Thank you GUys...OH wait...about the main shaft I know it's a bit long but I know how to solve that...I'll update this with my new pictures and how I install that main shaft system..and Again thank you...HAppy Thanks GIVING.....

PM  EMAIL  GALLERY  Attn:RR  Quote
11-24-2006 06:51 AM  11 years agoPost 2
bpd282

rrApprentice

littleton, co u.s.a.

My Posts: All  Forum  Topic

Nice-

I have a pair of plasti-blades and the super skids with a 9t motor and it flies good. No acrobatics but it is still very fun to fly. The key is having the dual tail mod with the 3s lipos. It sure looks way better with those skids. The boom supports never really went on right so I just took them off.

I have also flown it with the 3800kv motor from helidirect with a 9t pinion and it really screamed. The dual tail set up really held pretty well, even with the added headspeed.

I really like the microheli dual tail mod, but it hates the cheap esky motors from helidirect. The pinion on the tail motor does not mesh well and binds. The original eflite tail motors work very well.

That new main gear and shaft from helidirect looks good, let us know how it works.

PM  EMAIL  Attn:RR  Quote
11-24-2006 09:29 AM  11 years agoPost 3
Gino CP

rrKey Veteran

Philippines

My Posts: All  Forum  Topic

I pull out the Esky tail pinions and install the old EFlite ones. It works well. I just filed down an old tail motor armature to push the shaft out of the gear using my GWS gear puller.

I also encountered a gear mesh issue with ESky motors on the Blade CP. The mesh is a bit rought and I suspect that this is the cause of my burnt 4-in-1.

Anyone successfully used an ESky 9T motor on a Blade CP with flats or symmetricals and 11.1v lipo?

PM  EMAIL  Attn:RR  Quote
11-24-2006 04:23 PM  11 years agoPost 4
bpd282

rrApprentice

littleton, co u.s.a.

My Posts: All  Forum  Topic

Gino,

I used a 9t main Esky with my CP. The pinion was a little off, but it still flew well. The main did not have the mesh binding problems I have been having with the esky tail motors.

PM  EMAIL  Attn:RR  Quote
11-24-2006 05:42 PM  11 years agoPost 5
johnnycat500

rrApprentice

riverside,calif

My Posts: All  Forum  Topic

would like to see the pic.no picture here

PM  EMAIL  GALLERY  Attn:RR  Quote
11-24-2006 10:54 PM  11 years agoPost 6
Gino CP

rrKey Veteran

Philippines

My Posts: All  Forum  Topic

Now that is really strange. I still have no clue what fried my 4-in-1 in the Blade CP. I used an ESky 4-in-1, Esky 9T Pinion motor, 11.1v 1320mah 12c-15c lipo, flat bottom blades (also tried symmetricals.) I never exceeded 8 min each flight. 1st pack ok. 1st 5 min second back , fried.

Heli appears to be mechnically sound. That leaves the lipos as suspect.

PM  EMAIL  Attn:RR  Quote
11-25-2006 03:56 AM  11 years agoPost 7
BLADE CP GUY

rrApprentice

Houston, Texas- USA

My Posts: All  Forum  Topic

Fried??

MAybe PHIlippines is too hot for the blade cp...LOL JOKe..I miss my country man I hope I could just ride my blade cp from here to the Philippines...LOL...Have you crashed or landed in a grassy area with full throtle and stalling the tail mtor? Or Crashed on the Ground with FUll Throtle and stalled the main motor? well if you did once of twie, thats the time it starts to burn up or if you're luck it'll just heat up!!! Solution? There is one more bet for that to save you 4000 pesos, since auto parts in asia are cheap and everywhere, u can use a fuse and install it in both of your motor....if you dont know how to do that I'll try researching and give you all the instructions and everything...

PM  EMAIL  GALLERY  Attn:RR  Quote
11-25-2006 04:27 AM  11 years agoPost 8
Gino CP

rrKey Veteran

Philippines

My Posts: All  Forum  Topic

I'm having probs looking for 7.5amp mini fuse. Otherwise none of these would have happened.

Well,I have 4-in-1s coming next week and an Esky lipo. I'll be giving my 12c 11.1v lipos a rest and see if my probs go away.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 843 views POST REPLY
Helicopter
e-
Blade
Other › HI What Do you GUYs think of my new Body Set Up!!>??
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Thursday, January 18 - 9:58 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online