RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 356 views POST REPLY
Helicopter
e-
Align
Other › 401 and 9650 problems
11-22-2006 06:20 PM  11 years agoPost 1
Jason Chow

rrVeteran

La Crescenta, CA

My Posts: All  Forum  Topic

so i have no idea why all of a sudden i am getting this problem.

i set my tail as best as possible, via, center in rate mode, then subtrim it out till the heli is dead straight. then i make sure my limits at both ends are perfect. my travel adjust is the same, and my gain is where it always is.

problem: my piro rate left is slower, and i mean, way slower than right piro which is just insanely fast. i don't get it, nothing changed on my heli, nada.

any ideas????

PM  EMAIL  Attn:RR  Quote
11-22-2006 06:46 PM  11 years agoPost 2
caseyjholmes

rrElite Veteran

Portland, Oregon

My Posts: All  Forum  Topic

Not sure. I don't usually mess with piro rate in both directions. As long as the tail will turn both directions at any load time, I adjust for piro rate with my left thumb
Hows the tail shaft? Any notchiness to the tail blade grip bearings? Have you reamed the tail pitch slider ball links? (or do you use that new tail pitch slider w/o ball links?)

BTW.. everyone does the non HH subtrim thing but me, and I never seem to have a single issue that requires rudder subtrim or any drift issues with my gyro. Never found a reason to add any trim to my rudder channel on any heli but my XRB wireless. Even my SA with a CSM hlg gyro doesn't require trim to fly without drift. Might just be lucky..

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 356 views POST REPLY
Helicopter
e-
Align
Other › 401 and 9650 problems
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Sunday, January 21 - 3:01 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online