RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 415 views POST REPLY
ProModeler Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Jittering on PCM!!
03-08-2006 12:23 AM  11 years agoPost 1
Brett Horton

Key Veteran

---------

My Posts: All  Forum  Topic

Had a strange problem on this past Sunday.
I was setting up a Raptor 30V2 for a buddy. All was going well, got the pitch curves, throttle curves, hold, etc. setup. Fire the heli up, take it to the Heli pad to test hover it and I notice as I am checking control input that the swash plate is Jittering.... Hugh?
I check that the trans is PCM ... yes it is... cut the motor and take the heli back to the trailer. Range check it again, range checks great.
The Owner of the Raptor just put this RCVR in the heli, he had just gotten it back from Futaba from a check up (check up good).
Now remember this is a PCM radio (9ZWII) using a 149DP rcvr.
I could turn the heli on, try to start the motor with out using the glow igniter on it and the swash plate would jump around just like an FM would do experiencing interference
Long story short, we replaced the RCVR with a new one and all was perfect.
So what could cause a PCM RCVR to Jitter?
Obviously the RCVR is bad.
Any Ideas?

PM  EMAIL  GALLERY  Attn:RR
03-08-2006 02:26 AM  11 years agoPost 2
Chris Bergen

Elite Veteran

cassopolis, MI USA

My Posts: All  Forum  Topic

Cracked crystal??

just a WAG.

Chris D. Bergen

PM  EMAIL  GALLERY  Attn:RR
03-08-2006 03:07 AM  11 years agoPost 3
Brett Horton

Key Veteran

---------

My Posts: All  Forum  Topic

Yeah we thought of that also, but could that possibly cause jitters?
I would assume it would go into failsafe?

PM  EMAIL  GALLERY  Attn:RR
03-08-2006 09:13 AM  11 years agoPost 4
benovitch

Heliman

Belgium

My Posts: All  Forum  Topic

A few weeks a go I wass heving the same problem, when touching the leads that go in to te RX, also R149 DP my pitch whent up and down like crazy. so that wass the end of the flying day. back home i opend the RX and found out that the electric conection between two prints whas broken, five of ten chanels where riped lose from the print. I ve repaird it but still havend got a change to test it. staticly everithing workt fine.

PM  EMAIL  Attn:RR
03-08-2006 09:17 AM  11 years agoPost 5
nivlek

rrProfessor

Norfolk England

My Posts: All  Forum  Topic

Yeah we thought of that also, but could that possibly cause jitters?
I would assume it would go into failsafe?
Not if the interference was being picked up by the servo leads and going directly to the servos . I had this happen once on an electric plank (PCM Receiver), when I had put the wing on the aileron extension lead was too close to the esc and caused masive glitches on the aileron servo . The receiver remained uneffected so all the other controls worked fine .

At the end of the day , it gets dark .

PM  EMAIL  Attn:RR
WATCH
 1 page 415 views POST REPLY
ProModeler Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Jittering on PCM!!
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, August 21 - 9:29 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online