RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 444 views
HelicopterRadio - Servo - Gyro - Gov - Batt › lipo has died??? help
12-05-2005 12:58 AM  12 years agoPost 1
mdgyro

rrApprentice

Hawkinsville,GA

My Posts: All  Forum  Topic

I have a 2200mah lipo for my trex and I put it in today and it wouldn't spin the rotor fast enough to lift off IT IS FULLY CHARGED I put it back on the charger and in 5 minutes beep done put it back in heli won't lift off i have another one just like it and it does fine last time I flew this one it did fine what is up I don't know all there is to know about lipos so some input will help

PM  EMAIL  GALLERY  Attn:RR  Quote
12-05-2005 05:32 AM  12 years agoPost 2
helidad2

rrApprentice

potosi mo. usa

My Posts: All  Forum  Topic

what charger are you using

even a blind hog finds an acorn now and then

PM  EMAIL  GALLERY  Attn:RR  Quote
12-05-2005 11:19 AM  12 years agoPost 3
mdgyro

rrApprentice

Hawkinsville,GA

My Posts: All  Forum  Topic

triton

PM  EMAIL  GALLERY  Attn:RR  Quote
12-05-2005 02:57 PM  12 years agoPost 4
Lorents

rrElite Veteran

Oslo, Norway

My Posts: All  Forum  Topic

You have probably drained the battery so that it is below 3 volts per cell. Most chargers wont charge lipos that are drained too much.

Before you do anything you should check the voltage of the pack and see how far away it is from the 3 volts per cell...



What comes around goes around.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-05-2005 04:51 PM  12 years agoPost 5
mdgyro

rrApprentice

Hawkinsville,GA

My Posts: All  Forum  Topic

it's at over 12 volts when ck'd with meter

PM  EMAIL  GALLERY  Attn:RR  Quote
12-05-2005 04:53 PM  12 years agoPost 6
Dr Lodge

rrElite Veteran

Guildford, Surrey - UK

My Posts: All  Forum  Topic

Does your charger support a discharge cycle for LiPos? Might be worth putting it through such a cycle and see what that tells you. A fully charged 3s pack should be up near 12.6 volts.

Vibe 90, Vibe 50, Vigor CS x2,
Dyna-x, Knight 503D, Logo 10,
TRex 500, Furion, Gaui EP200

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-05-2005 10:11 PM  12 years agoPost 7
mdgyro

rrApprentice

Hawkinsville,GA

My Posts: All  Forum  Topic

Ia m going to cycle it tonight

PM  EMAIL  GALLERY  Attn:RR  Quote
12-06-2005 01:08 AM  12 years agoPost 8
mdgyro

rrApprentice

Hawkinsville,GA

My Posts: All  Forum  Topic

this battery will show 12.5 volts until you put a load on it and then it drops to 9.3 almost instantly it will hold at 9.3 for a minute or two then drop to 9 and the cycler stops I don' know what to do with it other than replace it is this how a lipo is suppose to act when it dies

PM  EMAIL  GALLERY  Attn:RR  Quote
12-06-2005 10:44 AM  12 years agoPost 9
Dr Lodge

rrElite Veteran

Guildford, Surrey - UK

My Posts: All  Forum  Topic

I don't know how a dead LiPo generally behaves, but looks like this one should be filed under b1n

Vibe 90, Vibe 50, Vigor CS x2,
Dyna-x, Knight 503D, Logo 10,
TRex 500, Furion, Gaui EP200

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 444 views
HelicopterRadio - Servo - Gyro - Gov - Batt › lipo has died??? help
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, December 12 - 11:50 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online