RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 634 views
Helicopter
e-
Hirobo Embla - SRB Quark - Lepton
› Blade not spining smooth?
12-04-2005 10:50 PM  12 years agoPost 1
jasonak

rrApprentice

wasilla.Alaska

My Posts: All  Forum  Topic

Hi just got my hrb and laminated the blades was flyig around and smacked the floor from about head high,Anyways the bottom blades dont just flow around like they used to they spin about half a turn and catch where as the top just spin around when you give them a little flip,its not bound up tight or anything just dosent have that free spin like it used to,I noticed that the gear down there now has a wobble moves up and down,Is the shaft bent do adjust the gear some how,or do i not worry abot it? Its still seems to fly fine.
thanks

PM  EMAIL  GALLERY  Attn:RR  Quote
12-05-2005 12:13 AM  12 years agoPost 2
Saint728

rrProfessor

Honolulu, Hawaii

My Posts: All  Forum  Topic

If it flys fine then don't worry about it. I wouldn't mess with it unless it wasn't flying.

Take Care,
Cheers, Patrick

Check the hotties in my Gallery
http://rc.runryder.com/helicopter/gallery/9019/?all=photo

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
12-05-2005 03:37 AM  12 years agoPost 3
jasonak

rrApprentice

wasilla.Alaska

My Posts: All  Forum  Topic

ok thanks
i just got it so you know i was just wanting to make sure that i wasnt screwing it up more bye flying it.
thanks again

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 634 views
Helicopter
e-
Hirobo Embla - SRB Quark - Lepton
› Blade not spining smooth?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Saturday, December 16 - 9:18 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online