RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 645 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Power stops at half throttle?
10-07-2005 01:26 PM  12 years agoPost 1
Hover-L-H

rrApprentice

Baraboo, WI

My Posts: All  Forum  Topic

Hi Folks,,,I need some help with my radio Jr.. I have a micro helicopter that I bought without any electronics. I added my own GWS 3-1 board and a GWS receiver. My problem is when I go to half throttle the power steadies and the heli only has enough power to just lift off the ground about 5". I know there should be more power and the throttle stick should be able to go past half throttle which will give the extra lift. I use this same radio on my Trex (different memory channel) and don't have any problem. I am missing something and I can't figure out what is wrong? Any suggestions?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2005 03:17 PM  12 years agoPost 2
Lorents

rrElite Veteran

Oslo, Norway

My Posts: All  Forum  Topic

Hi T-rexflyboy,

These symptoms could describe anything from a crazy radio setup to a slipping motor pinion

Do the GWS board have a "full power" indicator - like a diode blinking or something? If it does you could use that to make sure your radio are set up with 100% throtle at top stick.

For how long can you hover it before power decreases?

What is the state of your battery and motor?



What comes around goes around.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-07-2005 06:15 PM  12 years agoPost 3
Hover-L-H

rrApprentice

Baraboo, WI

My Posts: All  Forum  Topic

I may have found the problem!!!!

Thanks Lorents for your help,, The battery is new and I've used it on my ohter helicopters with no problem...The motor is brand new...The problem may be in the GWS and the way I got the tail motor and the main motor I think I got the plugs mixed up.. I don't believe they are plugged in correctlyI will see tonight when I get home....again thanks...

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2005 06:59 PM  12 years agoPost 4
Hover-L-H

rrApprentice

Baraboo, WI

My Posts: All  Forum  Topic

Problem is still there!!!

I checked and the connections are correct. That is not the problem. I loose power about 30 seconds after I start to hover....It must be the radio and somthing in the programing I just don't know were to look. When all else fails read the radio manual... I will give that a try this evening...I just don't under stand why the throttle stick will not give more power past 1/2 way up?????

PM  EMAIL  GALLERY  Attn:RR  Quote
10-09-2005 10:52 AM  12 years agoPost 5
Lorents

rrElite Veteran

Oslo, Norway

My Posts: All  Forum  Topic

If it first hovers at mid stick and then power is gradually lost after a few seconds I would suspect that your brushed motor or battery is not doing its job, but if they are brand new I guess it is something else.

What is the temperature on the motor and battery after flying?

Check that your motor pinion is not slipping. I have been fooled by a slipping pinion myself and it have the same symptoms. It will fly for a while and the pinion will slip more and more.



What comes around goes around.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-09-2005 11:15 PM  12 years agoPost 6
9387ASH

rrElite Veteran

UK

My Posts: All  Forum  Topic

If its a brushed motor, has it been run in ??

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 645 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › Power stops at half throttle?
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Thursday, November 23 - 6:55 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online