RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 1129 views
Scorpion Power Scorpion Power
HelicopterEngines Plugs Mufflers Fuel › Hyper trouble
10-06-2005 06:35 PM  12 years agoPost 1
Helijockey

rrKey Veteran

150 miles from​somewhere

My Posts: All  Forum  Topic

Hi guys, i have an OS50 hyper in my raptor 50. Recently the engine rpm increased on it's own to the extent that i had to alter the throttle curve Infact it seemed as if it was in ST1 mode! At the same time the engine sounds as if it's straining to deliver power. When it's in ST1 I can hardly tell because it's seems so similar to normal mode. I've reset the needles etc but still have a screaming engine which is down on power. I just can't figure out the problem and would appreciate ur thoughts on this.

PM  EMAIL  Attn:RR  Quote
10-06-2005 06:42 PM  12 years agoPost 2
Rappy30

rrApprentice

South Riding, VA -​US

My Posts: All  Forum  Topic

Never had the problem

Check your head bolts, back plate bolts and that your carb is on tight. Check you clunk line and all tubing for that matter. Sounds like your engine is going lean. Also check your in-line fuel filters for dirt/debris.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-07-2005 01:54 AM  12 years agoPost 3
Helijockey

rrKey Veteran

150 miles from​somewhere

My Posts: All  Forum  Topic

Rappy30, Desertsky thanks for ur posts. I already checked what Rappy30 suggested, all those things seem fine. I'm going to now check the clutch and take a look at the collective setup as suggested by Desertsky. I hope i can solve this in time for this weekends flying

PM  EMAIL  Attn:RR  Quote
10-07-2005 05:34 PM  12 years agoPost 4
Helijockey

rrKey Veteran

150 miles from​somewhere

My Posts: All  Forum  Topic

Hi Desertsky, the clutch seems ok. My pitch range in normal mode is -8/+11 and in ST1 -10/+10. Is this ok ? If i need to change it in normal mode, is it possible to do so without changing it in ST1?

PM  EMAIL  Attn:RR  Quote
10-09-2005 09:09 PM  12 years agoPost 5
turboomni

rrProfessor

East of the Equator

My Posts: All  Forum  Topic

Take the carb apart and clean it. I have had some running issues with my Hyper. Sometimes rich midrange ,or too lean up top , poor transitions from low to high,also sometimes fine till the end and it goes leaner and wails the rotor. Took my carb completely apart and found some small crud in there. Hopefully that will cure it. Maybe your problem too.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-10-2005 07:35 PM  12 years agoPost 6
Helijockey

rrKey Veteran

150 miles from​somewhere

My Posts: All  Forum  Topic

Will do turboomni, thanks

PM  EMAIL  Attn:RR  Quote
10-21-2005 02:49 AM  12 years agoPost 7
turboomni

rrProfessor

East of the Equator

My Posts: All  Forum  Topic

Helijockey, How did it turn out for you? Did you get the Hyper running well?
Like I said earlyier I took the whole carb apart and found some white plastic in granuals inside the carb so I cleaned it all out and reasembled it, sure is alot simpler than rebuilding a Quadrajet carb!!
Those were the days,,,,
Anyway I took up the Rappy with the Hyper out today and the motor is running Very well,,much better than before.
It still needs a GOV I feel,, but if I had too I could run it without.
Hope you have a happy ending as well.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2005 11:59 AM  12 years agoPost 8
crowfly

rrVeteran

Pleasant View, TN​U.S.A.

My Posts: All  Forum  Topic

Has the temperature dropped considerably at your flying field lately???

If God had meant for man to fly, he would have given him more money

PM  EMAIL  Attn:RR  Quote
10-21-2005 02:05 PM  12 years agoPost 9
turboomni

rrProfessor

East of the Equator

My Posts: All  Forum  Topic

It has dropped abit but it's not that there's more power, it just transitions better as I was having tuning issues

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2005 02:39 PM  12 years agoPost 10
turboomni

rrProfessor

East of the Equator

My Posts: All  Forum  Topic

I had found visible crud in my carb and my runs before the cleaning were Very inconsistant and no one needle setting would hold.
Now it's holding a setting pretty good.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2005 10:16 PM  12 years agoPost 11
HeliKopter Ken

rrKey Veteran

Gray, LA

My Posts: All  Forum  Topic

sounds like it was getting lean on you. Happened to my OS .37. Cleaned carb. and all was good. A little piston and sleeve scoring was the other problem with that trash in the carb. Doubled up on filters on my fuel can. Good luck and Fly smart.

Aurora, Raptor 90 FBL, Logo 600SX

PM  EMAIL  GALLERY  Attn:RR  Quote
10-31-2005 10:12 AM  12 years agoPost 12
Helijockey

rrKey Veteran

150 miles from​somewhere

My Posts: All  Forum  Topic

Hi turboomni, as u suggested i cleaned the carb and now the engine is fine. Thanks for all ur help

PM  EMAIL  Attn:RR  Quote
11-02-2005 05:04 AM  12 years agoPost 13
turboomni

rrProfessor

East of the Equator

My Posts: All  Forum  Topic

Great news,,What did you find in the carb>?
Curious to know as others may have the same problem

PM  EMAIL  GALLERY  Attn:RR  Quote
11-04-2005 01:28 PM  12 years agoPost 14
Helijockey

rrKey Veteran

150 miles from​somewhere

My Posts: All  Forum  Topic

Just found some small dirt particles, now i've put a larger filter on the fuel tubing which is on the fuel can. Also will check the filter on the tubing on the engine regularly.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1129 views
Scorpion Power Scorpion Power
HelicopterEngines Plugs Mufflers Fuel › Hyper trouble
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Saturday, November 25 - 7:18 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online