RunRyder RC
 11  Topic Subscribe
WATCH
 3 pages [ <<    <     1      2     ( 3 )    >    >> ] 2681 views POST REPLY
HelicopterThunder TigerOther › Blades going out of track during 3D manouvers
11-09-2005 07:17 AM  12 years agoPost 41
Olivier31

rrApprentice

France

My Posts: All  Forum  Topic

"Ido believe this flutter condition happened everytime regardless of blades ":

Yes, I'am OK with you. I'm experiencing THE problem since seven month and I've tried different baldes : NHP Razor, SAB, Mah, Funkey 3D and the blades going out of track during flight.... Sometimes, 1 or 2 times, and sometimes never... Very strange.

Regards from France
Olivier

PM  EMAIL  GALLERY  Attn:RR  Quote
11-09-2005 10:39 AM  12 years agoPost 42
Top End

rrApprentice

Darwin

My Posts: All  Forum  Topic

The only out of track I know of is when the blades BLATT on different air'os.
I have tried stock woodies and two types carbon aok.
All other bearings and shafts being spot on.
I did have a problem with yellow TreX blades on small electric and many many other people the same thing. Just we don't use them.

PM  EMAIL  GALLERY  Attn:RR  Quote
11-23-2005 05:06 AM  12 years agoPost 43
solidsnake

rrApprentice

Piscataway NJ, USA.

My Posts: All  Forum  Topic

I had this problem a few months ago while useing wood blades. It would happen during hard turns and when I brough the heli too a hover it would stop. Pretty scary when it happens. I tried different head speeds and it would still happen, check the ball links on the head, bearings everything still couldn't stop it from happening.

Then I totally switch too carbons and haven't had the problem again. I was using the wood blades because I had a few sets and wanted to use them up instead of paying $70 a set of TT blades.

Wood blades are worthless, would try fiberglass before ever using woods again.

PM  EMAIL  GALLERY  Attn:RR  Quote
11-27-2005 12:05 AM  12 years agoPost 44
flytech

rrVeteran

Sunland, CA

My Posts: All  Forum  Topic

just wanted to post my fix for my prob which was similiar (mine went out of track while inverted).

1. tri-flowed the red dampeners
2. found one of my thrust bearings was installed wrong with the race of the larger hole to the outside
3. applied grease to thrust bearings.

after this, tracked very nicely and consistenly upright, inverted and during transitions.

btw: admittedly, i did not know about the race with the larger hole until today.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 3 pages [ <<    <     1      2     ( 3 )    >    >> ] 2681 views POST REPLY
HelicopterThunder TigerOther › Blades going out of track during 3D manouvers
 Print TOPIC  Make Suggestion 

 11  Topic Subscribe

Wednesday, April 25 - 4:07 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online