RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 501 views POST REPLY
HelicopterEngines Plugs Mufflers Fuel › os70 szh noise under load?
05-08-2005 05:11 PM  12 years agoPost 1
P Johnston

rrVeteran

Ann Arbor MI

My Posts: All  Forum  Topic

Under load the engin emits a loud ticking or clicking sound. I took it out and cleaned, inspected, and put back in twice. I am sure that is coming from the engin. the heli is an X-Spec and is only a week old. The engin has about 2 gallons through it. I have replace the #8 glow plug and the fuel is CoolPower 30% and it is fresh. I was thinking of adding a head shim or putting a cooler plug in it. And yes agian, I am sure the noise is coming from the engin. Thanks for any advise.

Paul

PM  EMAIL  GALLERY  Attn:RR  Quote
05-08-2005 05:25 PM  12 years agoPost 2
nivlek

rrProfessor

Norfolk England

My Posts: All  Forum  Topic

Before you put a shim under the head , check out this link .

http://www.rcboat.com/cr.htm

I have posted this link before , and I know it's about model boat engines , but the principles are the same for our heli engines .

At the end of the day , it gets dark .

PM  EMAIL  Attn:RR  Quote
05-09-2005 09:43 PM  12 years agoPost 3
P Johnston

rrVeteran

Ann Arbor MI

My Posts: All  Forum  Topic

Thank you for that information. It was really helpfull.

PM  EMAIL  GALLERY  Attn:RR  Quote
05-10-2005 11:31 PM  12 years agoPost 4
P Johnston

rrVeteran

Ann Arbor MI

My Posts: All  Forum  Topic

It was the rear bearing. I put some oil in the bearing and something came unlodged and felt like gravel in there.

PM  EMAIL  GALLERY  Attn:RR  Quote
05-12-2005 03:35 AM  12 years agoPost 5
P Johnston

rrVeteran

Ann Arbor MI

My Posts: All  Forum  Topic

I'm kinda new to engin problems. I have never had an engin give ANY problems until I got this one. So the learning curve has been quite steep on this thing. OS has always been great to me but this OS70 has been trouble from about 1 gallon on.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 501 views POST REPLY
HelicopterEngines Plugs Mufflers Fuel › os70 szh noise under load?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Saturday, April 21 - 7:03 am - Copyright © 2000-2018 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online