RunRyder RC
 4  Topic Subscribe
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1256 views
HelicopterThunder TigerOther › Raptor 90SE new clutch failure
05-02-2005 04:32 PM  12 years agoPost 21
ddang

rrApprentice

Corona, CA

My Posts: All  Forum  Topic

Problem solved. It was the one way bearing in the auto hub. Replace it and now working fine.

Thank you EastCoast Extreme and Alexander. I think you guys hit the nail in the head. I did exactly what you suggested and got about 10 flights out of it and it fail again. So I replace it. I only wish Jeff has suggested it in the beginning instead of telling me to check the Jesus bolt and fasten the gear into the hub as though I was a beginner. If I was I wouldn't start out with the Raptor 90SE.

Anybody know TT number?

Thanks for all your help.

PM  EMAIL  Attn:RR
05-02-2005 10:49 PM  12 years agoPost 22
Jeff Swartz

rrKey Veteran

Ohio

My Posts: All  Forum  Topic

http://www.acehobby.com/acehobby/

It is listed at the top of the website.

PM  EMAIL  Attn:RR
05-02-2005 11:06 PM  12 years agoPost 23
Wa11banger

rrElite Veteran

Huntsville, Al

My Posts: All  Forum  Topic

Jeff, Since this post has been fixed I want to hijack it Can ya tell me what I did wrong with my R90? My one way on the start shaft stopped engaging. After taking it apart, I found alot of metal shavings around the top of the clutch.. very small markings on the inside top of the clutch bell so I don't think the clutch was directly rubbing the bell but maybe material was being drug around inside of it. But the start shaft end where it goes into the one way on the clutch is slaughtered, worn totally silver and gaulled. I know I need to replace the parts that is not a problem, but I own 4 of the Raptor 60/90 sized and cannot figure what I did to cause this issue. As far as I know alignment and gear mesh were perfect. I had recently put a YS motor in this one, and the vertical fit was tight to get the bolts in for the motor mount but not in the sense that I had to force anything into it. I did not have the the washer under the fan so I know that was not an issue as well. Any help or advice would be appreciated

Thanks
Rick

Proud member of the Quick UK, Duralite Flight Systems, V-Blade, & KBDD team

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1256 views
HelicopterThunder TigerOther › Raptor 90SE new clutch failure
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Thursday, January 18 - 2:04 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online