RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 896 views POST REPLY
Helicopter
e-
Align
Other › Align 400S + CC25 goes turbo when esc light is on?!?
12-09-2004 12:20 PM  13 years agoPost 1
msg73

rrApprentice

NJ

My Posts: All  Forum  Topic

I have an Align 400S 2800KV motor and CC25 ESC. When I throttle up, the rpm's smoothly increase. But when the red light on the ESC (100% throttle) turns on, the motor rpm's increases a lot. It's like all of a sudden, the motor goes into turbo. Anyone else experience this? Is this ok?

This happens In both fixed and auto-calibrating modes.

PM  EMAIL  GALLERY  Attn:RR  Quote
12-09-2004 03:18 PM  13 years agoPost 2
msg73

rrApprentice

NJ

My Posts: All  Forum  Topic

I'm hoping this is ok since I can't get decent power unless it's at 100% "Turbo Mode". At 100%, the power is acceptable and there's not too much bogging. I'm assuming that the motor/esc/battery will run cooler and more efficient at 100% throttle provided that I don't bog the motor too much.

I'm running fixed throttle mode with idle up 2 at 100 accross the board.

PM  EMAIL  GALLERY  Attn:RR  Quote
12-09-2004 05:51 PM  13 years agoPost 3
Orion_V

rrVeteran

Cliffside Park, NJ

My Posts: All  Forum  Topic

Mike...is there any reason why you aren't using governor mode?

PM  EMAIL  GALLERY  Attn:RR  Quote
12-10-2004 12:32 PM  13 years agoPost 4
msg73

rrApprentice

NJ

My Posts: All  Forum  Topic

The Align motor is an outrunner. CC ESC don't work well with outrunner motors. I think they're working on updating the software, but for now, I can't use gov mode.

How's your rex doing with the mega?

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 896 views POST REPLY
Helicopter
e-
Align
Other › Align 400S + CC25 goes turbo when esc light is on?!?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Monday, January 22 - 8:36 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online