RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 606 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › TJ Pro Help Needed
10-24-2004 11:20 PM  13 years agoPost 1
Southern Raptor

rrNovice

Loxley Alabama

My Posts: All  Forum  Topic

I just set up a TJ Pro on my Raptor 90. I am using the Futaba 9chp radio. Went through the set up just as it is listed, everything seemed fine, calibrated with no problem and the sensor was lighting when the magnet passes. Went to the field and when the governor is turned on the engine starts fluctuating up and down. I had a more experienced pilot that flies a TJ look at it and we recalibrated and changed the numbers in the radio but when it was activated it started the up and down with the rpms. Any suggestions?

If I agreed with you, We would both be wrong!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2004 12:51 AM  13 years agoPost 2
George Matthews

rrElite Veteran

N.W. Ohio

My Posts: All  Forum  Topic

What servo are you using for the throttle ?

George Matthews

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2004 12:54 AM  13 years agoPost 3
Southern Raptor

rrNovice

Loxley Alabama

My Posts: All  Forum  Topic

Servo

9451 Futaba Digital

If I agreed with you, We would both be wrong!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2004 01:41 AM  13 years agoPost 4
jhodges68

rrNovice

Savannah, Georgia

My Posts: All  Forum  Topic

Mine does the EXACT same thing with a S9253. I have calibrated in super servo and non super servo to no avail. If I use a Hitec HS525BB, it works fine ???

It seems to hate my digital servo

Johnny Hodges
Savannah, Ga

PM  EMAIL  Attn:RR  Quote
10-25-2004 01:58 AM  13 years agoPost 5
George Matthews

rrElite Veteran

N.W. Ohio

My Posts: All  Forum  Topic

Are you calibrating the TJ in super servo mode ?

George Matthews

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2004 02:10 AM  13 years agoPost 6
Southern Raptor

rrNovice

Loxley Alabama

My Posts: All  Forum  Topic

Both

Tried calibrating in both modes. Same result

If I agreed with you, We would both be wrong!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-25-2004 03:28 AM  13 years agoPost 7
Wa11banger

rrElite Veteran

Huntsville, Al

My Posts: All  Forum  Topic

I had the same problem.. The fix was to match your th curves more closely to the headspeed.. The TJ has to be within a certain percent of the actual speed to engage properly.. It only seems to matter for the initial engaging of the TJ.. ID1 and ID2 dont seem to matter what your pitch curve is..

Just my .02
Rick

Proud member of the Quick UK, Duralite Flight Systems, V-Blade, & KBDD team

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-25-2004 06:59 AM  13 years agoPost 8
DOKEY

rrProfessor

Northamptonshire UK

My Posts: All  Forum  Topic

Also poor engine tuning can cause the RPM to change erratically.

Ryan.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-25-2004 01:18 PM  13 years agoPost 9
jhodges68

rrNovice

Savannah, Georgia

My Posts: All  Forum  Topic

I've calibrated in all modes ... engine tuning is spot on and the curves are not out of whack. It just hates the digital servo. Same engine tuning, same curves, regular servo ..... works great. Go figure ?

Johnny Hodges
Savannah, Ga

PM  EMAIL  Attn:RR  Quote
10-25-2004 03:19 PM  13 years agoPost 10
Wa11banger

rrElite Veteran

Huntsville, Al

My Posts: All  Forum  Topic

I run nothing but a digital servos with my TJ's both experienced the same issue until I corrected my Th Curves and recalibrated.. You have to recal everytime you mess with the throttle

Just my .02
Rick

Proud member of the Quick UK, Duralite Flight Systems, V-Blade, & KBDD team

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-25-2004 07:02 PM  13 years agoPost 11
Southern Raptor

rrNovice

Loxley Alabama

My Posts: All  Forum  Topic

Throttle Curve

I think you may be on to something there wa11banger. I just got a pm from the pilot that was helping. He thinks we may have had too low a number put in the radio and the actual throttle curve was a much higher head speed. Going to try again with a different number. I have the 8.45 ratio on my Raptor and if my friend's info is correct going to try a number of 73 in the radio which should work out to an approximate 1530 headspeed. Anyone out there running a TJ with this ratio on there 90 size heli and if so what numbers are you having to put in???

If I agreed with you, We would both be wrong!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-29-2004 08:20 PM  13 years agoPost 12
Southern Raptor

rrNovice

Loxley Alabama

My Posts: All  Forum  Topic

Solved Problem

I went into the radio and changed the numbers. It solved the problem. Governor is working fine.

If I agreed with you, We would both be wrong!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 606 views
Scorpion Power Scorpion Power
HelicopterRadio - Servo - Gyro - Gov - Batt › TJ Pro Help Needed
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Thursday, November 23 - 9:37 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online