RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 531 views
Scorpion Power Scorpion Power
HelicopterEngines Plugs Mufflers Fuel › Please Help, Lots of white smoke?
10-22-2004 05:06 AM  13 years agoPost 1
Chopper1

rrApprentice

San Francisco Ca

My Posts: All  Forum  Topic

i just traded a used x cell pro with a os 61 engine. i just got it running and notice that the engine is running a bit wird. there are LOT of white somke coming from the exhaust and doesn't seems to have any power.

what can be the problem?

any adice?

thank you

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-22-2004 06:20 AM  13 years agoPost 2
Puffy929

rrApprentice

N W Ohio

My Posts: All  Forum  Topic

sounds a little on the rich side....try leaning it out a little....

TRex600Nitro YS 50 JR9303Converted to 2.4 TJ Pro

PM  EMAIL  GALLERY  Attn:RR  Quote
10-22-2004 04:09 PM  13 years agoPost 3
caz

rrApprentice

Warwickshire

My Posts: All  Forum  Topic

What fuel are you using?

Magnum fuel is well known for its cloud of white smoke.
If you are using any of the other fuels available then as Puffy929 says lean the engine up a bit.

You're only young once; you can be immature forever.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-23-2004 01:58 AM  13 years agoPost 4
Chopper1

rrApprentice

San Francisco Ca

My Posts: All  Forum  Topic

magnum

yes, i am using magnum fuel 20%

maybe, i'll try some cp15. thanks

is there any way to tell if the engine is bad?

thank you very much

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 531 views
Scorpion Power Scorpion Power
HelicopterEngines Plugs Mufflers Fuel › Please Help, Lots of white smoke?
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Friday, November 24 - 11:27 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online