RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 757 views
Scorpion Power Scorpion Power
HelicopterThunder TigerOther › Engine Help please?
10-20-2004 03:18 PM  13 years agoPost 1
dankers

rrVeteran

Melbourne, Australia

My Posts: All  Forum  Topic

I recently converted from Micros to the real thing, a Rappy 50. Coming from the electric world, glow power is fairly new and the learning curve is a bit steep with one thing, the engine. First flight was on Saturday, just hovered half a tank before the glow plug died, too lean I think by a long way. Not good for the TT50 for it's first flight.

I really need help here, the Rappy is perfect but my engine skills, ug.

Bought a few new glow plugs today (OS #8) and have run 4 tanks through it but I am not sure at all about the mixture or if something is really wrong.

Started out at 2.5 turns out, not as much smoke as I would like, 3 turns out, a little more smoke, 5 turns out and it still leans out on decent. When it was too lean, it sounds like its missing and the tail shudders - I think this is too lean anyway.

So another turn out, I'm hovering and see fuel dripping, the needle valve has fallen out. Still not masses of smoke and the engine still runs. First, I hope I can get a new needle valve, second what is going on?

I heard that if the engine is too rich, it won't even start? Started at 5 turns out on the main neddle, I can't even get it to run real rich.

I hoping I haven't done perm damage to the thing but more than anything I want this baby to run great. The setup is now real nice, it flies so well, stable goes where its put and I'm loving it.

Feel like just buying a OS50 and starting again as the break-in is screwed already I think?

I'm sorry for the vaugeness of this, I can fly to a good level, I know heli setup fairly well (except for one small build error with the rappy) but engines, man am I lost!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-20-2004 03:34 PM  13 years agoPost 2
gamedemon3000

rrApprentice

Goose Bay,​Newfoundland &​Labrador, Canada

My Posts: All  Forum  Topic

ive written about this many times, and ill post some links, look for the posts with my name to see what i had to say. to get the gist of it tho, the tt 50 depends highly on the low needle, you might as wall forget the high needle. and dont worry, even if you think youve ruined the engine itll probally only cost around 30 dollars to fix. have a look at my first piston after 4 tanks

and then the new one after a gallon

here are the links to to other times i helped with this engine

http://www.runryder.com/helicopter/t134443p1/
http://www.runryder.com/helicopter/t135621p1/
http://www.runryder.com/helicopter/t135402p1/

and if you need any more with this, ill try to help if i can

Derek O'B

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-20-2004 03:35 PM  13 years agoPost 3
gt900uk

rrKey Veteran

Scotland

My Posts: All  Forum  Topic

Hey m8 this is a pretty good engine but it has 2 screws sounds like you need to adjust the low speed screw. This affects the mixture from idle up to about half way then the high speed takes over. Set the high speed to 4-4.5 turns out just now and the low speed (which is inside the throttle arm body) to about 6-7 to try. This is just my experience so if anyone knows better batter in. Once u get the heli running hover it for 20secs or so and land it. Put you finger on the backplate and feel how hot it is if its cold lean the low speed needle out a bit half turn at a time. If its too hot richen the bottom end. You should be able to hold your finger on the backplate for 5-6 seconds before its unbearably hot. U do not wanna run this engine lean. What fuel u using? There should be a nice amount of smoke. The heli may sound like its missing if its 2 rich this is OK just now untill it is broken in. Run it on the rich side for a gallon then start leaningt out for more power always keep it on the rich side though it dont like being 2 lean. If it still seems lean check the pressure line from the exahuast is OK.

This Heli Will Self Destruct In Five Seconds!!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2004 02:47 AM  13 years agoPost 4
dankers

rrVeteran

Melbourne, Australia

My Posts: All  Forum  Topic

I'm sure the low end was too lean, thanks for the help, this is starting to make sense.

All I need to find out now is if the thing is damaged. The first ever flight, I know I over heated the engine, it hovered for 2 minutes and the last 30 seconds of that the engine was losing power. I landed it, went to idle and it dies. That was 4 days ago and not the best thing to do to a new Engine.

Yesterday, I ran 4 tanks through it. It had power and started perfectly every time. The low needle was too lean but in hover it was fine, no missing and some smoke but not loads. All I did was hover it really and a few test climb outs on the 3rd and fourth tank. So, this Engine has not had a kind break-in but does seem to run still.

Any advice? What should I be looking for?

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-21-2004 12:03 PM  13 years agoPost 5
gt900uk

rrKey Veteran

Scotland

My Posts: All  Forum  Topic

It will prob be OK just dont let it run hot now. Try not to run it a full power till it is broken in. If u take the exahust off u can see the piston. It should be nice and clean looking urs may be black but if the engine is running OK the chances are it will be fine. I wouldnt worry about it set it up properly and fly it im sure it will be fine

This Heli Will Self Destruct In Five Seconds!!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2004 12:45 PM  13 years agoPost 6
Zilly

rrVeteran

UK

My Posts: All  Forum  Topic

If your Idle needle is set to lean, it is in the hover that you will do the most damage as you are still relying on the idle needle settings to keep it rich enough. As you apply more power you are coming into the main needles band of control so you will probably find if you have it wound right out that it would start to bog down.

z

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2004 12:56 PM  13 years agoPost 7
CrashExpert

rrApprentice

Scotland

My Posts: All  Forum  Topic

GT900UK:

What would be the result of your engine if you were to run it too lean??? ROFL



Crash
601 Crew Member
Your about to be Cloned!!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-21-2004 12:59 PM  13 years agoPost 8
gt900uk

rrKey Veteran

Scotland

My Posts: All  Forum  Topic

I dunno u tell me. What happened wasnt a result of lean running...... Read about it is a problem Doh

This Heli Will Self Destruct In Five Seconds!!

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 757 views
Scorpion Power Scorpion Power
HelicopterThunder TigerOther › Engine Help please?
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Friday, November 24 - 9:37 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online