RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 648 views
Scorpion Power Scorpion Power
HelicopterEngines Plugs Mufflers Fuel › OS50 problems
10-20-2004 02:31 AM  13 years agoPost 1
manarb

rrNovice

Tampa, FL

My Posts: All  Forum  Topic

I have a raptor 50 with OS50 that I cannot get to run right. I can usually get in a good first flight with no problems. After landing and idling for a few seconds it will not accelerate beyond the transition from low to high. Subsequent attempts at flight are met with the same condition - the engine just quits in the transition phase. I tried the cat eye mod with no improvement - bought another cat eye system and no improvement. Went to and idle bar plug and can get it to move to high end but is very rich. One click of the needle to lean and it will quit again. I've tried every combination of low and high needle settings that I can think of and still no improvement. HELP!! Short of buying a 60L carb or a new hyper engine - what can I do. One flight and 30 attempts per day is making me not like flying helicopters.

Leo

PM  EMAIL  Attn:RR  Quote
10-20-2004 02:53 AM  13 years agoPost 2
HelicopterJohn

rrKey Veteran

Seffner, Florida​(Just East of Tampa,​Florida)

My Posts: All  Forum  Topic

Fuel lines & header tank

Leo,

You might want to try by passing the header tank in case it has a restriction. Sometimes the holes are not drilled out good enough and it causes a restriction.

Also, check the fuel tubing inside the main tank.

Stop by the Brandon Field and we can take a look at it and see if I can help.

OC Bob's Gathering #2 was a Premiere Event. Pictures in my Gallery

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-20-2004 04:01 AM  13 years agoPost 3
kamlooper

rrApprentice

kamloops

My Posts: All  Forum  Topic

Curious, was the engine ever run lean for any lenght of time?

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2004 12:49 PM  13 years agoPost 4
RICH.L

rrKey Veteran

east springfield​p.a.

My Posts: All  Forum  Topic

are you running a hot enough glow plug,like the os#8 or an enya #3?
i had that problem last year and it was driving me nuts.
i put an enya in it richened it up and runs great.
it was only an os32,but should be the same concept.
and by the way,what is a cat eye mod?
rich

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2004 12:56 PM  13 years agoPost 5
2LTime

rrKey Veteran

Walworth,NY

My Posts: All  Forum  Topic

Leo, I wouldn't spend anymore money. I would try and get some help from a local experienced flyer. That is a good engine and shouldn't be giving you that much trouble. I would take helicopterjohn up on his offer. Also, as mentioned the plug can make a big difference. get an os #8.

Jeff

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2004 03:36 PM  13 years agoPost 6
manarb

rrNovice

Tampa, FL

My Posts: All  Forum  Topic

Plugs

Thanks guys for your responses. I will take Helicopter John up on his offer. I was using OS8 plugs (several) but a change to an old K&B idle bar allowed me to transition without too much trouble.

PM  EMAIL  Attn:RR  Quote
10-20-2004 09:21 PM  13 years agoPost 7
AshleyDavis

rrApprentice

Southampton, UK

My Posts: All  Forum  Topic

Had exactly the same problem, enya #3 fixed it.

Ashley.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 648 views
Scorpion Power Scorpion Power
HelicopterEngines Plugs Mufflers Fuel › OS50 problems
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Thursday, November 23 - 9:08 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online