RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 1570 views
Scorpion Power Scorpion Power
HelicopterGasser Model RC HelicoptersOther › Hirobo Bell 47G2 engine problem
10-19-2004 10:27 PM  13 years agoPost 1
Jon Chmielowski

rrNovice

My Posts: All  Forum  Topic

Hey guys I have the original Hirobo Bell 47G2 helicopter with the 20cc EH engine, I bought it off of ebay but the whole bird including the engine was brand new and never even seen fuel before, I finally got it all together and test run without the rotors several times the engine starts and runs fine at low settings but when you get it up to full power it sputters and does not develope any where near full power. I changed the spark plug to the original one, re-gaped it, and still the same thing im using 88 octane gasoline with a 50:1 mixture, the plug is not burning clean and I even tuned the carb for high and low mixture settings, still no change. Does anyone have any ideas for this problem, it uses the original amplifier box with a seperate 6 volt battery source for ignition and the wires are all hooked up right and always use fresh batteries. Im not new to rc helis but this is my first gasser and even though I have tuned many small two cycle engines before, never have I run into one with a timming advance linkage or 6 volt ignition source, could it be that I may need to advance the timming from factory settings?? Thanks for any help with this guys. Jon

PM  EMAIL  Attn:RR  Quote
10-20-2004 02:32 AM  13 years agoPost 2
FCM

rrElite Veteran

Surrey, England

My Posts: All  Forum  Topic

I have heard from a guy who used to fly the same machine as you that the timing advance as standard, meant that the timing was too advanced at high power (hover+) settings.

From memory, I think he shortened the cable to restrict the amount of advance and then it performed okay. I think it was a trial and error adjustment though but I guess it wouldn't be too difficult to try?

Hope this helps,

Paul.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2004 11:54 AM  13 years agoPost 3
Jon Chmielowski

rrNovice

My Posts: All  Forum  Topic

Bell 47G-2 problem

Hey thanks I will try that, I was kind of figuring it would be a timming problem just didnt know which way to go with that, but will certainly try both ways, I switched to Amsoil with a 50:1 mixture as my engine is broken in by now but still wondering if this is maybe too little oil. Im also still developing some glitches still, I mounted the amplifier box and battery with switch in its own wooden box mounted behind the engine on the frame as far away from the reciever and antenna as possible but I think there is some other things going on with metal to metal noise possibly the tail rotor drive shaft in the pipe. I did however ground the brass pipe to the tail truss to arrest some of the problems will try again tomorrow even though its been acting like winter here now days. Thanks Jon.

PM  EMAIL  Attn:RR  Quote
10-20-2004 01:10 PM  13 years agoPost 4
FCM

rrElite Veteran

Surrey, England

My Posts: All  Forum  Topic

I've just been through a huge interference issue with my gasser cameraship. It turned out to be serveral thigs all happening at or around the same time! Very difficult to isolate them all without loads of testing.

I would thoroughly recommend what I was advised here on RR when I was 'suffering' and that is to change your spark plug for a new one before you try anything else - it might be that easy!

Good luck with it and keep us posted.

Paul.

PM  EMAIL  GALLERY  Attn:RR  Quote
10-20-2004 01:12 PM  13 years agoPost 5
FCM

rrElite Veteran

Surrey, England

My Posts: All  Forum  Topic

One other thing Jon,

You may be running too much Amsoil if the plug won't clean up. Seems that most of the Amsoil users here run at 64:1 ratio but it may be different with your particular engine.

Paul.

PM  EMAIL  GALLERY  Attn:RR  Quote
11-03-2004 10:03 PM  13 years agoPost 6
tisse6

rrNovice

Roxenbaden Vreta​Kloster Sweden

My Posts: All  Forum  Topic

Hirobo Bell47 problem

Hi guys,
I have had exactly the same problem with my Hirobo Bell 47 20 cc gasser.
Not enough power for flight. I bought a completely new Swedish ignition system called RUNTRONIC designed by Rune Svenningsson in Sweden. His ignition system is known all over the world as one of the best. His company name is "Modeller och Elektronik"
and is located here in Sweden.
After I changed the ignition system from the original to his, the chopper is flying completely wonderfull and I am using the original sparkplug and the oilmix is 2.5% syntetic.
Have a try it's worth it!
Regards Kent Thisell

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1570 views
Scorpion Power Scorpion Power
HelicopterGasser Model RC HelicoptersOther › Hirobo Bell 47G2 engine problem
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Friday, November 17 - 11:09 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online