RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 883 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › Help me get it up safley guys!!
10-18-2004 05:41 PM  13 years agoPost 1
active

rrNovice

South Wales

My Posts: All  Forum  Topic

Hi all,
I am hoping some one can help me out with a little problem that I have, here's the story......(Oh, please remember I am a bit of a newbie to helis).

I bought a new OS 32 engine for my shuttle as the old engine (a OS 28) was starting to play up. Anyway, fitted the engine and started the heli up no problem. Then things went a little wrong.

I was increasing the throttle and the new engine started screaming away and I thought that because it was a .32 and I used to have a .28 that this screaming was probably normal. So I increased the throttle a little more to where the old .28 engine wolud start to lift the heli off the ground, but nothing happened except the engine screamed enen louder.

I gave the engine a little more throttle and suddenly the heli shot up into the air at about 100 Mph - I nearly had heart failure and the big brown mark that was left in my underpants tells the story of how I was feeling watching my heli shoot up into the air!

Anyway, got it down safley (still shaking now about 45 mins later).

I began to examine my heli and noticed that on 0% of my throttle to 50% throttle the pitch increases on my main blades increases from nothing to full pitch by the time I get to 50% throttle.

And then from 50% throttle upwards no increase in the main blade pitch is noticable.

I think my problem is that the increase in pitch should occure at about 50% throttle and upwards instead of the lower half of my throttle range.

Am I right? If so, (or even if I am completly wrong) can anyone offer some advice on what I need to do to fix my problem?

Thanks Guys,


.A.

PM  EMAIL  Attn:RR  Quote
10-18-2004 05:58 PM  13 years agoPost 2
bazler

rrApprentice

Swindon, UK

My Posts: All  Forum  Topic

where are you?

Baz.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-18-2004 05:59 PM  13 years agoPost 3
active

rrNovice

South Wales

My Posts: All  Forum  Topic

Hi Baz,
Im in Newport - South Wales

PM  EMAIL  Attn:RR  Quote
10-18-2004 06:00 PM  13 years agoPost 4
greenboot

rrVeteran

Marblehead, OH

My Posts: All  Forum  Topic

what I need to do to fix my problem?
Dude, you need to soak those shorts in warm soapy water before the stain takes a set.

About your heli, sounds like you answered your own question. If you mention what kind of radio you have, someone will tell you exactly what button to press. The blades should gradually increase in pitch from -4 to 9 degrees for beginner helis

Tom

PM  EMAIL  Attn:RR  Quote
10-18-2004 06:00 PM  13 years agoPost 5
bazler

rrApprentice

Swindon, UK

My Posts: All  Forum  Topic

If you can make Swindon there's plenty of help available with your set up.....

Baz.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-18-2004 06:01 PM  13 years agoPost 6
craneyum

rrKey Veteran

warwickshire uk

My Posts: All  Forum  Topic

Hi active

Fill in the rest of your profile and this may help us to help you. What radio are you useing.
Nigel

Learn By Other Peoples Mistakes It Costs Less

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-18-2004 06:03 PM  13 years agoPost 7
active

rrNovice

South Wales

My Posts: All  Forum  Topic

Hi,
They are soaking as we speak, had to add a bit of bleach though to get them back to their original white colour

I am sure that nothing has been reversed on my radio, I just changed the engine thats all! So I thought that it would keep all its settings from the old )S .28 engine.

Anyway, just incase anyone cam help my radio is a JR XP662.

THanks

.A.

PM  EMAIL  Attn:RR  Quote
10-18-2004 06:05 PM  13 years agoPost 8
craneyum

rrKey Veteran

warwickshire uk

My Posts: All  Forum  Topic

Active go into your pitch curve on your radio and post the values at low mid and high.
Nigel

Learn By Other Peoples Mistakes It Costs Less

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-18-2004 06:06 PM  13 years agoPost 9
active

rrNovice

South Wales

My Posts: All  Forum  Topic

Hi guys,
Just updated my profile

PM  EMAIL  Attn:RR  Quote
10-18-2004 06:24 PM  13 years agoPost 10
active

rrNovice

South Wales

My Posts: All  Forum  Topic

Hi,
Just checked my radio and here are the settings of the pitch curve:

Low = 40%
Center = 50%
High= 62%

Thanks

PM  EMAIL  Attn:RR  Quote
10-18-2004 06:37 PM  13 years agoPost 11
craneyum

rrKey Veteran

warwickshire uk

My Posts: All  Forum  Topic

If you have a pitch guage take readings at low mid and high and then post them.
Nigel

Learn By Other Peoples Mistakes It Costs Less

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-18-2004 06:42 PM  13 years agoPost 12
flysacessna

rrNovice

Florida

My Posts: All  Forum  Topic

is it possible

is it possible that you accidentally flipped an idle up switch? i have the same radio and setting it up can be tricky... but maybe your idle up switch was turned on.. Have you set up your radio for any other curves besides the one you've been using... If not, I'd guess that you may have bumped a switch... into a flight mode that isn't set up properly, just an idea

[b]Me fail English? That's unpossible![/b]

PM  EMAIL  Attn:RR  Quote
10-18-2004 07:02 PM  13 years agoPost 13
active

rrNovice

South Wales

My Posts: All  Forum  Topic

Hi,
Just put my pitch gauge on the baldes and here is what I get:

Low = 9 deg
Mid= about 16 deg. (Its off the scale)
High = Just goes completly off the scale.

PM  EMAIL  Attn:RR  Quote
10-18-2004 07:20 PM  13 years agoPost 14
vinrx7

rrVeteran

Americas finest city

My Posts: All  Forum  Topic

holly **** man!
i didnt even know you could get that much pitch even if you wanted to.
why are you starting at 9 deg? try something more like -2 and go to +9. Something must have changed because just changing the engine would not change your pitch curve like that. Plus the carb is different on different make engines so you cant assume that mid throttle will be at the same travel of the servo that you had before.
good luck and be sure to use lots of bleach on those shorts.

STUPID TREE!!!

PM  EMAIL  GALLERY  Attn:RR  Quote
10-18-2004 07:40 PM  13 years agoPost 15
greenboot

rrVeteran

Marblehead, OH

My Posts: All  Forum  Topic

You're settings are so far off you need to go back to the instructions and start over. Put the radio back to it's default settings and adjust the linkage lengths to whatever it says in the manual. Then go from there. It will take a couple hours, but you need to do it. Get some help if you can because it is tricky the first time.

Tom

PM  EMAIL  Attn:RR  Quote
10-18-2004 08:00 PM  13 years agoPost 16
active

rrNovice

South Wales

My Posts: All  Forum  Topic

Thanks for all your help guys.

Ive been playing around witt the pitch settings all night and one minute I can get 0 deg at low 5 deg at mid but then when I get to full throttle the needle just goes off the scale and I cannot get it to sit at 9 deg.

Never mind though, winter is almost here in the UK so I will just pack up my heli for the next few months and then get it to a shop in the spring.

Thanks all.

.A.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 883 views
Scorpion Power Scorpion Power
HelicopterMain Discussion › Help me get it up safley guys!!
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, November 20 - 1:50 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online