RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 465 views
Scorpion Power Scorpion Power
HelicopterEngines Plugs Mufflers Fuel › Metallic noise!!?
10-18-2004 08:47 AM  13 years agoPost 1
Moskitofan

rrNovice

UK

My Posts: All  Forum  Topic

I have a Robbe Moskito Conquest with a Webra 50 engine. Recently it has developed a strange noise while in flight. At first I thought it might be the tube drive rattling on the boom due to the support moving. I checked this and it is fine. I also checked the clutch and the main drive gears and bearings and they all seem fine.

The problem only seems to happen when I am in idle up and flying circuits. When I reduce collective/throttle it seems to make this strange noise as though there is something metallic that is loose.

I have read about pre-ignition and wondered if this could be the cause. The engine runs with OS No.8 on 10% prosynth 2000 and is very reliable though I have to say it was second hand and I don't know its history.

Any ideas.

PM  EMAIL  Attn:RR  Quote
10-18-2004 04:13 PM  13 years agoPost 2
rob_jones

rrKey Veteran

Perry, GA

My Posts: All  Forum  Topic

Sounds like the rear bearing in the engine.

Blade 550X, T-Rex 450 Pro FBL

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
10-19-2004 02:23 AM  13 years agoPost 3
2LTime

rrKey Veteran

Walworth,NY

My Posts: All  Forum  Topic

Take off your muffler and shake it. I have had the baffles inside come loose.

Jeff

PM  EMAIL  GALLERY  Attn:RR  Quote
10-19-2004 09:13 AM  13 years agoPost 4
Moskitofan

rrNovice

UK

My Posts: All  Forum  Topic

Thanks for the replies,

Bimmer, I changed the engine last night (I have a spare)! when i took the engine apart, I was surprise to find quite a lot of black carbon deposits on the piston crown head and arond the liner. There was also a fair bit of scoring in the bore. The engine is not in as good shape as I thought! The bearings don't feel too bad, but there is evidence of corrosion on them. The safest bet is to retire it I think.

Jeff, I checked the exhaust and that seems OK. but I will keep an eye on it.

I will test fly again at the weekend.

On the original question of pre-ignition, does anyone have an opinion on whether 10% nitro is too much for the Webra? I use 10% because I also have an OS60 and 10% seemed to be a good compromise.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 465 views
Scorpion Power Scorpion Power
HelicopterEngines Plugs Mufflers Fuel › Metallic noise!!?
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Wednesday, November 22 - 7:22 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online