RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 850 views
Helicopter
e-
Electric Battery-Charger-pSupply
› Lipo batteries get hot
06-06-2004 02:23 AM  13 years agoPost 1
kaptkaos

rrKey Veteran

Miami FL

My Posts: All  Forum  Topic

I have various Lipo packs

eTec 1200 3s
Tanic 850 3s
TP 1320 3s
eTec 700 3s
eTec 700 2s

They all get really hot during a run, but the motor, esc, and tail motors stay really cool. The TP battery is BRAND NEW. What is wrong?

I charge with a Triton

Thanks

If you give a Chimp a gun, and the Chimp shoots, DONT BLAME THE CHIMP!!!!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-06-2004 03:34 AM  13 years agoPost 2
rscamp

rrVeteran

Ontario, Canada

My Posts: All  Forum  Topic

What is the current draw with your setup?

Rob

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-06-2004 05:31 AM  13 years agoPost 3
kaptkaos

rrKey Veteran

Miami FL

My Posts: All  Forum  Topic

I have no idea, I dont have eq to find that out, everything but the battery is cool.

If you give a Chimp a gun, and the Chimp shoots, DONT BLAME THE CHIMP!!!!

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-06-2004 12:13 PM  13 years agoPost 4
rscamp

rrVeteran

Ontario, Canada

My Posts: All  Forum  Topic

I would check current first. Buy or borrow a Whattmeter or clamp on ammeter.

Rob

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 850 views
Helicopter
e-
Electric Battery-Charger-pSupply
› Lipo batteries get hot
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, December 11 - 11:30 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online