RunRyder RC
 0  Topic Subscribe
WATCH
 1 page 613 views
HelicopterRadio - Servo - Gyro - Gov - Batt › glitches with TJ Pro
06-05-2004 01:45 AM  13 years agoPost 1
jack33

rrKey Veteran

USA Wallkill, New York

My Posts: All  Forum  Topic

anyone have a glitching prob with there setup after installing a TJ Pro?also the range test falls short,didn't have this prob prior to install of TJ Pro.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-05-2004 05:39 AM  13 years agoPost 2
staraero1

rrKey Veteran

Atlantic City, New Jersey

My Posts: All  Forum  Topic

Is your antenna placement in the same area as before, after you installed the T.J. Pro? I have heard of a couple units which caused glitches, but never a range problem. Let us know what you find.

Also, if you have a governor problem Model Avionics is first class when it comes to warranty, and exchanging the one you have for another unit. If you think this is the case send it to them, or send them an email.

I bet you get another governor in the mail straight away. Even before they get your defective unit returned to them. Send Paul Beard at Model Avionics an email here, if you determine the T.J. pro is faulty.

info@modelavionics.com

They are decent people to deal with on any issue concerning their equipment.

Staraero1

PM  EMAIL  Attn:RR  Quote
06-05-2004 11:28 AM  13 years agoPost 3
jack33

rrKey Veteran

USA Wallkill, New York

My Posts: All  Forum  Topic

hi Staraero1


yes, the ant was in the same area, i also went as far to replace the rec with another that has the standard ant,the range prob is solved with either rec,but i get these hits off and on still.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 613 views
HelicopterRadio - Servo - Gyro - Gov - Batt › glitches with TJ Pro
 Print TOPIC  Make Suggestion 

 0  Topic Subscribe

Wednesday, December 13 - 7:34 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online