RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 454 views
06-04-2004 04:52 AM  13 years agoPost 1
X30pilot

rrApprentice

Plano, TX -USA

My Posts: All  Forum  Topic

I have had a ball with the CP, but when I first got it I went to hell and back trying to get this thing to run smooth. After much work I did get the blades balanced. After many great flights I wiped out the blades showing a friend a nose in hover in his garage. I was not looking forward to spending the time to balance another set of blades but to my surprise the replacement blades came balanced right out of the bag and ran reasonably smooth.
Was my CP shipped with bad blades?

PM  EMAIL  GALLERY  Attn:RR  Quote
06-04-2004 11:20 AM  13 years agoPost 2
Ben-T-Spindle

rrProfessor

Central Illinois

My Posts: All  Forum  Topic

I had the exact same experience. The blades that come with the CP were so bad that I could never get them to run smooth. The next set of stock semi symmetrical blades were balanced and run very smooth. They are so smooth that I can now run more gyro gain.

... BTS

PM  EMAIL  GALLERY  Attn:RR  Quote
06-04-2004 02:28 PM  13 years agoPost 3
pbmax

rrKey Veteran

Olympia, WA - USA

My Posts: All  Forum  Topic

Yeah, same experience. Awful blade balance combined with wobbly plastic head block == horrible vibration. I'm waiting for like90 HB CP blades myself.

pbmax

PM  EMAIL  GALLERY  Attn:RR  Quote
06-05-2004 01:26 AM  13 years agoPost 4
ericfly

rrApprentice

Cornwall, UK

My Posts: All  Forum  Topic

My son recently got a cp and his blades were badly out of balance.

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
WATCH
 1 page 454 views
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Wednesday, December 13 - 1:01 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online