RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 387 views
HelicopterMain Discussion › OS32 quits running
06-01-2004 11:01 PM  13 years agoPost 1
Ron_M

rrApprentice

Ft. Lauderdale, Florida

My Posts: All  Forum  Topic

I've flown about 4 gallons through this engine without any problems until today. After flying for about 10 minutes I started to need to increase throttle to maintain hover, so I landed and increased the high speed needle 3 clicks. Ran better for another 10 minutes, then had the same problem and, again, I turned the high speed needle 3 more clicks out. About 10 minutes later the engine seemed fine until all of a sudden it just stopped. Doesn't seem too hot, and I think I've checked everything I can think of...fuel lines, etc. Any suggestions?

Raptor 30 V2 GY-401; Futaba 9253 JR X-378 Wildcat 30%

PM  EMAIL  Attn:RR  Quote
06-01-2004 11:08 PM  13 years agoPost 2
Naomi

rrElite Veteran

Ontario, Canada

My Posts: All  Forum  Topic

I would suggest you drop the engine, make sure all your engine bolts are tight., fuel filter is clean clean up your carb.. then try again..

Naomi

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-01-2004 11:18 PM  13 years agoPost 3
Fullagas

rrKey Veteran

Michigan

My Posts: All  Forum  Topic

.
Ditto what Naomi sez, plus make sure the low-end (idle) needle is on the rich side. That, and make sure your fuel hasn't gotten any water in it from opening/closing the fuel bottle repeatedly.


.

Flying helis since gyros had springs.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 387 views
HelicopterMain Discussion › OS32 quits running
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, December 11 - 11:26 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online