RunRyder RC
 7  Topic Subscribe
WATCH
 1 page 1037 views
HelicopterMain Discussion › radio failure! - PROBLEM SOLVED!
06-01-2004 05:15 PM  13 years agoPost 1
Branzzz

rrVeteran

Singapore

My Posts: All  Forum  Topic

i had a crash earlier on, where i had absolutly no control over my raptor, when it was just over two metres away. the tx antenna was fully extended when it crashed.. a range check later with the antenne fully extended and retracted are both 2metres. i've finally got time to diagnose the problem, and i would like to know from you guys with your experience, what could possibly cause the radio to lock out? i need to know what to do before i buy anything, as i'm just a 16 year old student with only my daily lunch to skip for buying parts.

Raptor 50V2
OS 50SX-Hyper
GY502/9253
Hitec 6975
Airtronics ERG-VB
JR 3810

PM  EMAIL  Attn:RR  Quote
06-01-2004 05:18 PM  13 years agoPost 2
Dexter

rrApprentice

North Wales, UK. Not England.

My Posts: All  Forum  Topic

I dunno about the cause of your lockout, but personally, I wouldn't fly 2 metres from myself (or anyone else)...

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2004 05:57 PM  13 years agoPost 3
nivlek

rrProfessor

Norfolk England

My Posts: All  Forum  Topic

Sounds like maybe your tx antenna may not be connected inside the tx.

PM  EMAIL  Attn:RR  Quote
06-01-2004 06:16 PM  13 years agoPost 4
Darksider

rrKey Veteran

Derby United Kingdom

My Posts: All  Forum  Topic

sorry to hear about your crash, if it's always worked b4 then just suddenly did this i'd say it's the crystal, often vibration over long periods of use just messes them up, try replacing it first and then check your range again.

Gareth

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2004 06:34 PM  13 years agoPost 5
reddragon

rrElite Veteran

Brooklyn, N.Y.

My Posts: All  Forum  Topic

Those crystals do go from time to time. Good call.

Wayne - Fly it like you stole it! You're in good hands with Runryder!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2004 07:03 PM  13 years agoPost 6
duraace9sp

rrApprentice

los angeles area

My Posts: All  Forum  Topic

radio failure

---unless u were hit by someone...can u rule that out, which u can if its repeatable

PM  EMAIL  Attn:RR  Quote
06-03-2004 06:18 PM  13 years agoPost 7
Branzzz

rrVeteran

Singapore

My Posts: All  Forum  Topic

i've since bought a new RX crystal to try out. after installing the crystal, i noticed that the range problems were still there. i then took out the module from my tx to have another look and placed it back in. to my amazement, it worked this time. i did i lil range check in my house and the servos went dead after about 10m. i took out the module again and put it back, and tried it again with the old rx crystal. now i've been able to get a good 30m with the antenna down. i am not totally secure with it. what should i check? has anyone experienced this before?

Raptor 50V2
OS 50SX-Hyper
GY502/9253
Hitec 6975
Airtronics ERG-VB
JR 3810

PM  EMAIL  Attn:RR  Quote
06-03-2004 06:30 PM  13 years agoPost 8
Darksider

rrKey Veteran

Derby United Kingdom

My Posts: All  Forum  Topic

sounds like you may have a transmitter problem then, u could try changing the crystal in the tx aswell, but if that didn't give perfect and conclusive results right away, i'd just send it in for service and get it professionally checked, it's really not worth risking another crash.

Gareth

PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2004 06:32 PM  13 years agoPost 9
Branzzz

rrVeteran

Singapore

My Posts: All  Forum  Topic

i got my jr347 second hand, but the module seems new. i'm a newbie, so where can i send my radio to get serviced? how much would it cost?

Raptor 50V2
OS 50SX-Hyper
GY502/9253
Hitec 6975
Airtronics ERG-VB
JR 3810

PM  EMAIL  Attn:RR  Quote
06-03-2004 06:37 PM  13 years agoPost 10
archangel

rrApprentice

Pasadena, CA - USA

My Posts: All  Forum  Topic

I would suggest that you find the nearest Service Center by going on the JR webpage.

Once you find it send the Tx, Module and the RX so that they can tell you that the whole system is working properly.

PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2004 06:47 PM  13 years agoPost 11
reddragon

rrElite Veteran

Brooklyn, N.Y.

My Posts: All  Forum  Topic

Agreed archangel. You need to send the ENTIRE system in for a complete analysis and check. This is why they are there, to help. It does appear that you have a serious transmitter issue right now. I am not sure how much it will cost since the price may vary from country to country. They will charge your for the diagnostic and then they may charge for labour and parts if needed. Good luck and PLEASE let us know what happens and if they find any problems. It helps when we know what the problem is and how it was solved.

Wayne - Fly it like you stole it! You're in good hands with Runryder!

PM  EMAIL  GALLERY  Attn:RR  Quote
06-03-2004 06:57 PM  13 years agoPost 12
Brian Bennett

rrKey Veteran

Dugway/Tooele UT, USA

My Posts: All  Forum  Topic

Send it in.

Brian

Team MRC-Hirobo and Model Avionics Rep

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
07-12-2004 03:45 AM  13 years agoPost 13
Branzzz

rrVeteran

Singapore

My Posts: All  Forum  Topic

i took the module apart and found that the chipset in the module had gotten lose from the module casing, so in effect, when the module was plugged into the tx, the pins and crystal would not contact properly. all JR users take note.

Raptor 50V2
OS 50SX-Hyper
GY502/9253
Hitec 6975
Airtronics ERG-VB
JR 3810

PM  EMAIL  Attn:RR  Quote
07-12-2004 04:00 AM  13 years agoPost 14
Isaac F

rrKey Veteran

Panama Republic of Panama

My Posts: All  Forum  Topic

i took the module apart and found that the chipset in the module had gotten lose from the module casing, so in effect, when the module was plugged into the tx, the pins and crystal would not contact properly. all JR users take note.z
You are saying that the chip get unsolder from the pc board inside the module???

PM  EMAIL  GALLERY  Attn:RR  Quote
07-12-2004 04:11 AM  13 years agoPost 15
Branzzz

rrVeteran

Singapore

My Posts: All  Forum  Topic

the chip inside the module got loosened from its module casing. when i placed the module inside the tx, ,the pins of the tx and crystal pushed it off, so there was no or poor connection. in a normal module, the chip should stay secure inside its casing, so when i put the module into the tx, the pins of the tx wouldn't push the chip away, and it would result in good connections...

Raptor 50V2
OS 50SX-Hyper
GY502/9253
Hitec 6975
Airtronics ERG-VB
JR 3810

PM  EMAIL  Attn:RR  Quote
07-12-2004 04:14 AM  13 years agoPost 16
Twobeers

rrKey Veteran

Toronto, Canada

My Posts: All  Forum  Topic

Send it in dude. It could very well be that either the contacts for the module are corroded or are simply loose from being removed and put back onece to often. or it could also be an electronic componet that heats up quickly and quits working. Is it still under warranty, if so it won't cost you more than the postage. If not, it shouldn't be to expensive to repair, least ways, cheaper than fixing your heli after a crash.

I lost my infamous tag line.

PM  EMAIL  GALLERY  Attn:RR  Quote
07-12-2004 04:21 AM  13 years agoPost 17
Branzzz

rrVeteran

Singapore

My Posts: All  Forum  Topic

it works absolutly fine now. ive secured it to the module casing and it wont move. ever

Raptor 50V2
OS 50SX-Hyper
GY502/9253
Hitec 6975
Airtronics ERG-VB
JR 3810

PM  EMAIL  Attn:RR  Quote
07-12-2004 09:02 PM  13 years agoPost 18
Darksider

rrKey Veteran

Derby United Kingdom

My Posts: All  Forum  Topic

Glad to hear you got it sorted branzzz

Gareth

PM  EMAIL  GALLERY  Attn:RR  Quote
07-13-2004 12:51 AM  13 years agoPost 19
9387ASH

rrElite Veteran

UK

My Posts: All  Forum  Topic

Whilst you are at it, take a look at the contacts on the radio that feed into the module. make sure that there is no sign of BWC. Clean them with a rubber or a fibreglass pen.

This is another cause of intermittant transmit problems.


PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 1037 views
HelicopterMain Discussion › radio failure! - PROBLEM SOLVED!
 Print TOPIC  Make Suggestion 

 7  Topic Subscribe

Monday, December 11 - 7:10 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online