RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 392 views
Helicopter
e-
Century Radikal E640 - Swift 16 NX
› My new control board seems wrong?
06-01-2004 09:58 AM  13 years agoPost 1
BodwadUK

rrNovice

UK Notts

My Posts: All  Forum  Topic

A while back i bought a new control board because i fried the original. First i noticed that one of the wires was really short and now i notice that as the battery goes the tail begins to go. Eg if start to lose power in the tail but not the main motor. I am sure that my old one didnt do that. When the power goes i thought it was supposed to effectively land not do a super twirl and crash.

Anyone else know of this. Is it right.

PM  EMAIL  Attn:RR  Quote
06-01-2004 10:19 AM  13 years agoPost 2
hingus2000

rrKey Veteran

West Midlands UK Posts: 75069

My Posts: All  Forum  Topic

one of the wires (i think to the gyro!?) is meant to be short, and yes i think most people start to fight the tail when they lose power.

Tom

T-Rex SA, Anodized Head, Gy240, 3s TP 2100mah, Align 35A ESC, 430L Motor

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
06-01-2004 02:27 PM  13 years agoPost 3
BodwadUK

rrNovice

UK Notts

My Posts: All  Forum  Topic

Ok thanks

as long as know because i couldnt remember my old one being like that

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 392 views
Helicopter
e-
Century Radikal E640 - Swift 16 NX
› My new control board seems wrong?
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Thursday, December 14 - 9:02 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online