RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 962 views
05-31-2004 10:38 PM  13 years agoPost 1
DirtDevil

rrNovice

South Africa

My Posts: All  Forum  Topic

I am new to electric helis,so i bought a Zoom 400-great fun but the other day the motor stopped and the servos shut down so could not even do a auto.I am running a himax 4200,using etech 11.1v 1200mah batteries and a modelmotors 25a esc.What i want to know is this normal.when do you know its time to land as the motor was not slowing down to give a indication the battery is flat.Which is the best way to set up your heli or is it a trial and error situation that takes timing of how long you fly.Any help please

My mother-inlaw's wheel chair is trail-rated

PM  EMAIL  Attn:RR  Quote
06-02-2004 10:44 PM  13 years agoPost 2
steph

rrKey Veteran

Hampshire England

My Posts: All  Forum  Topic

Li-po low battery warning indicator



Try this site https://secure.electricrotors.co.uk/ Look under humming bird parts right down the bottom of the page

PM  EMAIL  GALLERY  Attn:RR  Quote
06-02-2004 10:52 PM  13 years agoPost 3
cnsheets

rrApprentice

Anaheim, Ca

My Posts: All  Forum  Topic

sounds like you have the low-voltage cutoff set wrong on the ESC.

That is if it is even programmable.

---Freya Evo TJ Pro/Rev Max(rep) Magnum(rep)

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 962 views
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Thursday, December 14 - 10:58 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online