RunRyder RC
 1  Topic Subscribe
WATCH
 1 page 832 views
HelicopterMain Discussion › definative answer
05-31-2004 09:42 AM  13 years agoPost 1
foo

rrVeteran

Richfield, Minnesota

My Posts: All  Forum  Topic

i would like a final answer what swash type do you use for hummingbird elite CP, i try the one the instructions say to use and the elevator is reversed, meaning when i push the stick the rotor disc tilts the wrong way, then i try a different one and i found one that all the controls work right on, but its not what the book says to use

its a rd6000 tx

Raptor 30 v2 / OS .32 / JR 8103 / GY-401+9253 | Raptor 50 V2 / OS .50 Hyper

PM  EMAIL  Attn:RR  Quote
05-31-2004 10:12 AM  13 years agoPost 2
scottc

rrKey Veteran

shakopee minnesota..USA

My Posts: All  Forum  Topic

i would use the one that works all the controls

PM  EMAIL  GALLERY  Attn:RR  Quote
05-31-2004 01:49 PM  13 years agoPost 3
Al Magaloff

rrMaster

12,199 Posts- Enough Time Wasted. See Ya!

My Posts: All  Forum  Topic

I don't use a swashplate on my Hummingbird.
.

PM  EMAIL  Attn:RR  Quote
05-31-2004 02:18 PM  13 years agoPost 4
copperclad

rrElite Veteran

NY

My Posts: All  Forum  Topic

hi foo
you could try useing the recommended one and reverseing your elevator channel , with m eco-8 they wanted a certain swash type and it didnt work at first either , they dont know what kind of radio you have but they do know what kind of swash they want , all tx's are set up slightly different and you will need to mess with them to get them to work , are they asking for 90 degree and you are useing 120 or visa versa?

PM  EMAIL  GALLERY  Attn:RR  Quote
05-31-2004 08:48 PM  13 years agoPost 5
hondaboy945

rrApprentice

Lakewood, CO

My Posts: All  Forum  Topic

Dont know if this helps but on my Futaba the I use SR-3, look in your manual for the swashplate settings (i.e 120 degrees)

PM  EMAIL  Attn:RR  Quote
05-31-2004 09:46 PM  13 years agoPost 6
foo

rrVeteran

Richfield, Minnesota

My Posts: All  Forum  Topic

when i just reverse the el it makes the collective not do all 3 servos at once.

Raptor 30 v2 / OS .32 / JR 8103 / GY-401+9253 | Raptor 50 V2 / OS .50 Hyper

PM  EMAIL  Attn:RR  Quote
05-31-2004 09:54 PM  13 years agoPost 7
copperclad

rrElite Veteran

NY

My Posts: All  Forum  Topic

hi foo
in the swash screen on my set i see a list like
elv +50
ail +50
pit +50
try setting elv to -50
in the swash screen

PM  EMAIL  GALLERY  Attn:RR  Quote
06-01-2004 07:55 AM  13 years agoPost 8
foo

rrVeteran

Richfield, Minnesota

My Posts: All  Forum  Topic

so no one can actually tell me what swash mode they personally use with the hb cp and the rd6000 ???

im damn sure the way i have it is right cuz the disc tilts the right ways, but man this heli is J-U-N-K out of the box

Raptor 30 v2 / OS .32 / JR 8103 / GY-401+9253 | Raptor 50 V2 / OS .50 Hyper

PM  EMAIL  Attn:RR  Quote
06-01-2004 08:04 AM  13 years agoPost 9
hondaboy945

rrApprentice

Lakewood, CO

My Posts: All  Forum  Topic

I had some of the same problems as you did although I have a different radio. Did you look in the manual for the radio, it helped me alot. I also striped the heli and rechecked and checked and checked. If it helps any

PM  EMAIL  Attn:RR  Quote
06-01-2004 02:28 PM  13 years agoPost 10
mobywho

rrApprentice

Duluth, GA

My Posts: All  Forum  Topic

foo,

Have you call Century for support?

PM  EMAIL  Attn:RR  Quote
06-02-2004 02:43 AM  13 years agoPost 11
Stretched

rrApprentice

Mobile, Alabama

My Posts: All  Forum  Topic

The HB is CCPM right?

Sounds like the AFR is on the wrong setting.


Go to the swash setup menu on your radio, and change the elevator AFR to -50%. Most radios are set default to +50%.

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 832 views
HelicopterMain Discussion › definative answer
 Print TOPIC  Make Suggestion 

 1  Topic Subscribe

Sunday, December 17 - 11:29 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online