RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 745 views
HelicopterThunder TigerOther › R30v2 won't hover anymore, what up?
05-02-2004 11:40 PM  13 years agoPost 1
Helimex

rrApprentice

Oklahoma

My Posts: All  Forum  Topic

I was flying along fat, dumb and happy the other day when the damn thing got a little too far away from me and I lost the orientation. It fell out of the sky and you know the rest of the story. Anyway, I've rebuilt and I'm flying again. The problem I'm having is that it will not come to a hover unless I have the pitch trim knob maxed out to the right. (JR8103). It flies great when it's maxed out but when I take it to the zero position it will not even try to lift of with max collective. What gives? I'm not sure where to start looking for the problem, pitch curve, throttle curve, linkage? Anyone have any ideas? I know this can't be too serious of a problem 'cause it flies fine as long as I got pitch trim maxed out.

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
05-03-2004 12:29 AM  13 years agoPost 2
tailrotordave

rrVeteran

Burbank, Ca

My Posts: All  Forum  Topic

Assuming you hover at midstick, set your Tx to midstick and put your pitch gauge on the blades (check both). They should be at 5 or 6 degrees positive. This is a good place to start.......

PM  EMAIL  GALLERY  Attn:RR  Quote
05-03-2004 01:11 AM  13 years agoPost 3
Helimex

rrApprentice

Oklahoma

My Posts: All  Forum  Topic

When I put it all back together a few days ago, I set my pitch at -4,6,9 so I'm not sure that's where the problem is but I'm going to check it again, maybe I read the pitch gage wrong. Assuming the pitch is ok, is there anywhere else I should be looking?

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
05-03-2004 01:57 AM  13 years agoPost 4
ScareCrow_Delta

rrVeteran

Sebastian, FL

My Posts: All  Forum  Topic

Sometimes out of track blades can cause that.

~~~~ Defy the laws of gravity....gracefully ~~~~

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
05-03-2004 09:30 PM  13 years agoPost 5
jscott55

rrNovice

Madison, WI

My Posts: All  Forum  Topic

Check your engine setup. It may be going too slow...

PM  EMAIL  Attn:RR  Quote
05-05-2004 05:31 PM  13 years agoPost 6
mbrick350

rrNovice

Piqua, Ohio. USA

My Posts: All  Forum  Topic

I'm having that same problem on my 30 as well with that same set up and my blade are tracking good. i have to turn the pitch nob all way to right. If you track down this problem let me know. thanks.

PM  EMAIL  Attn:RR  Quote
05-05-2004 08:40 PM  13 years agoPost 7
tweb

rrApprentice

uk

My Posts: All  Forum  Topic

a mate had the same kind of trouble
he put the ovel loop links to the head on up side down
worth a look?

PM  EMAIL  Attn:RR  Quote
05-06-2004 12:08 AM  13 years agoPost 8
Helimex

rrApprentice

Oklahoma

My Posts: All  Forum  Topic

Solved the problem

It seems that when I put the heli back together again since my last crash I had the pitch knob maxed out to begin with, therefore, when I set my pitch curve (-4,6,9) it was set with pitch trim dialed in. I simply zeroed the knob and reset my blade pitches with the gage and all is well now.

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
WATCH
 1 page 745 views
HelicopterThunder TigerOther › R30v2 won't hover anymore, what up?
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Tuesday, December 12 - 4:41 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online