RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 773 views
HelicopterHIROBOOther › something is not right!
05-02-2004 09:35 PM  13 years agoPost 1
Storm

rrApprentice

CALIFORNIA

My Posts: All  Forum  Topic

Ive bought almost all the head upgrades for my Freya 60...to run a YS91.. only remaining would be the carbon lower frames and she would be an x-spec. still flutters like Crazy. bought MAH blades initially, had the worst flutters ever, then upgraded the yoke, metal auto hub, 3rd bearing block, push pull upgrade, metal guide pins, metal washout. still fultters, then I bought SAB Blades, did not flutter as much.. but still flutters. Now ive read on another post to buy Metal grips???? whats up with that. Im running out of options. Should I just get another brand of machine?? I was so bummed out today after trying her out with the new blades. Everything was fine until I idled up. right when I hovered 10 feet, It fluttered like crazy that I almost lost it. I got so scared that my machine almost went out of control. I landed her right away and went home!. ....any other ideas other than spending another dime on this machine???

PM  EMAIL  Attn:RR  Quote
05-02-2004 09:47 PM  13 years agoPost 2
white chocolate

rrKey Veteran

Baltimore, Md.

My Posts: All  Forum  Topic

flutter

Well you see my other post. I dont know bout the metal grips but you have everything else lol!!! Just make sure you have zero slop in the head system. I hate to say it but try some vblades too!! It didnt flutter at all when I tried those. I just like mahs so I was determined. Also how many flights do you have on the freya. What servo are you using?

The freya is an awesome heli so dont give up. I got mine to stop so its possible.

PM  EMAIL  GALLERY  Attn:RR  Quote
05-02-2004 09:54 PM  13 years agoPost 3
Storm

rrApprentice

CALIFORNIA

My Posts: All  Forum  Topic

After all the upgrades, 1.5 gallons, most of which spent hovering breaking in the engine. now that its about ready to go, experiencing this flutter.. Headspeed about 1750 Spanking new damper just installed yesterday with the mah 690 blades. Im using 8311 on cyclics and collective.

PM  EMAIL  Attn:RR  Quote
05-02-2004 10:36 PM  13 years agoPost 4
sluggo

rrElite Veteran

Kitchener Ont

My Posts: All  Forum  Topic

Hi Storm I had the prob with my first X-spec. After going through everything I found my pitch servo was loose. You really have to tighten it down (if loose it will cause the heli to flutter) also make sure none of your balls are loose.

Hope this helps.

Chris

Teambob00

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
05-03-2004 12:51 AM  13 years agoPost 5
ZZ3Astro

rrVeteran

Panama City, Fl

My Posts: All  Forum  Topic

A couple of things here...

1>Make sure you have the push/pull upgrade on the collective system...

2>Try different blades.. I've heard of MAH and Freya being a questionable combo.. and definitely avoid Maveriks.

3>Lower your headspeed... run 8.45 ratio with the 90 and keep the headspeed around 1750-1800

4>cleaned up
zz3

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
05-03-2004 12:52 AM  13 years agoPost 6
white chocolate

rrKey Veteran

Baltimore, Md.

My Posts: All  Forum  Topic

lol

zz

PM  EMAIL  GALLERY  Attn:RR  Quote
05-03-2004 01:01 AM  13 years agoPost 7
sluggo

rrElite Veteran

Kitchener Ont

My Posts: All  Forum  Topic

HAHAHA ZZ I feel for you! I am not sure if it is a MAH thing or not. I have had the flutter with both MAH and SAB'S. Storm is also having trouble with both blade types.

I think any blade that leads (unstable) will cause a flutter problem but there is more to it then just the blades. There is a ton of people out there flying both blade types without any trouble at all. There has to be something working with it that is causing it to happen.

Like I said before after tightening up my pitch servo the flutter went away. Other people have found other things that fixed the problem. Just like the woof and poof on rappys that took for ever to figure out and they still do it. I also had very bad flutter on my milli with V's and it turned out to be a bad thrust bearing.

Storm if you can grab a pair of new V's and see if that helps you out.

Chris

Teambob00

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
05-03-2004 01:02 AM  13 years agoPost 8
Jason Cummings

rrVeteran

St. Louis

My Posts: All  Forum  Topic

I traced flutter down on mine with mah's to a worn blade grip. One was able to flap more than the other. Slop on a freya with mah blades is a bad combo.

Synergy Field Rep

PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR  Quote
05-03-2004 01:13 AM  13 years agoPost 9
Storm

rrApprentice

CALIFORNIA

My Posts: All  Forum  Topic

Thanks for your suggestions, I will have to order a new pair of Vs and CX dampers. see if that would help. It just disappoints me that Ive spent more time spending money and waiting for parts than flying since Ive upgraded...

PM  EMAIL  Attn:RR  Quote
05-03-2004 01:28 AM  13 years agoPost 10
traderdave2

rrVeteran

Covington, GA

My Posts: All  Forum  Topic

You can also move the arm on the push pull lever in and the ball on the main pitch lever out to reduce the magnification of the slop in servo gear train. Of course you will have to increase the atvs to keep the same pitch range. What is your atv at right now? And what pitch range do you get from it?

Its also quite easy to flip the head over on the freya. It flies slightly different.

Harlan

PM  EMAIL  GALLERY  Attn:RR  Quote
05-03-2004 01:56 AM  13 years agoPost 11
Storm

rrApprentice

CALIFORNIA

My Posts: All  Forum  Topic

Ive already done that Harlan. Im now @ 120 +/- atv with +/- 13.5 degrees pitch max. Im currently using up to 10 plus/minus degrees until i get this flutter problem sorted out. thanks bro.

PM  EMAIL  Attn:RR  Quote
05-04-2004 12:38 AM  13 years agoPost 12
funder

rrApprentice

Houston Texas @ JSC field

My Posts: All  Forum  Topic

flutter

I had the same problem and cured it with the one piece servo hold down. You know the metel ones that go over both rubber servo gromets.

PM  EMAIL  Attn:RR  Quote
05-04-2004 06:34 AM  13 years agoPost 13
Storm

rrApprentice

CALIFORNIA

My Posts: All  Forum  Topic

Jeff called me today and explained different areas that I need to check. I will be working on it today as time permits. Ill start tracking it down from 0 pitch(where flutter manifests) to swash plat slop, Ill replace linkages as well. My 70 has been up and running since november last year without problem, It just started when I upgraded to 90 engine withMAH blades. Ill update you as to what happens.

funder, I do have the one pice servo mounts on. thanks for sharing in

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 773 views
HelicopterHIROBOOther › something is not right!
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Tuesday, December 12 - 11:49 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online