RunRyder RC
 3  Topic Subscribe
WATCH
 1 page 1100 views
Helicopter
e-
Electric General Discussion
› Hitec Eclipse 7 programming
04-30-2004 03:45 AM  13 years agoPost 1
Roel

rrNovice

Toronto, Ontario Canada

My Posts: All  Forum  Topic

Can someone tell me why I'm having a hard time trying to program my hitec eclipse 7 with a 4 channel electric helicopter?...the channels don't seem to be correct and there doesn't seem to be a way to switch the channels around???

PM  EMAIL  GALLERY  Attn:RR  Quote
04-30-2004 05:56 AM  13 years agoPost 2
pbmax

rrKey Veteran

Olympia, WA - USA

My Posts: All  Forum  Topic

Hrm, first off, do you have it set to heli mode? Standard swash is what you want, which is the default. Could you describe your problem with the channels?

I fly my hummingbird with an Eclipse 7 and it works great.

pbmax

PM  EMAIL  GALLERY  Attn:RR  Quote
04-30-2004 11:59 AM  13 years agoPost 3
Roel

rrNovice

Toronto, Ontario Canada

My Posts: All  Forum  Topic

Ok, I got it working, I moved the plugs around on the receiver, I had the plugs set the way it was when I was using the GWS transmitter, anyways the channels are now correct but Its working with in ACRO mode...i'll try doing the HELI mode like you said set to NORmal mode...be right back.

PM  EMAIL  GALLERY  Attn:RR  Quote
04-30-2004 12:22 PM  13 years agoPost 4
Luxor8

rrNovice

Olympia, WA. USA

My Posts: All  Forum  Topic

Is this a collective machine. If it's Fixed pitch there is no need whatsoever to program heli functions.
Just curious cause this doesn't sound right.


Eric S.

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
04-30-2004 02:21 PM  13 years agoPost 5
pbmax

rrKey Veteran

Olympia, WA - USA

My Posts: All  Forum  Topic

Yeah, you can fly it in acro mode, or heli standard swash. Acro mode is fine until you want to turn on revo mixing or use remote gyro gain or something like that. For CCPM, of course, heli mode is a must.

pbmax

PM  EMAIL  GALLERY  Attn:RR  Quote
05-01-2004 04:26 AM  13 years agoPost 6
Roel

rrNovice

Toronto, Ontario Canada

My Posts: All  Forum  Topic

Its a fixed pitch heli...anyways I got everything to work now just wondering what your throttle curve percentage is? I have mines set at 100% anything less then that the phoenix 10 won't arm.

PM  EMAIL  GALLERY  Attn:RR  Quote
05-01-2004 05:35 AM  13 years agoPost 7
pbmax

rrKey Veteran

Olympia, WA - USA

My Posts: All  Forum  Topic

Yup, for a FP heli, 0, X, 50, X, 100 is probably what you want, where X means the point is disabled. If the P10 won't arm, try adding some negative trim on the throttle channel (I had to do this for one of my planes).

pbmax

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 1100 views
Helicopter
e-
Electric General Discussion
› Hitec Eclipse 7 programming
 Print TOPIC  Make Suggestion 

 3  Topic Subscribe

Monday, December 11 - 11:31 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online