RunRyder RC
 2  Topic Subscribe
WATCH
 1 page 624 views
HelicopterJR Heli Vibe 90/50, Sylphide 90, GSR260 › JR Vent. 30 Clutch problem
04-29-2004 05:01 PM  13 years agoPost 1
C130nut

rrNovice

Madison, Ms

My Posts: All  Forum  Topic

My JR Venture 30 has been totally rebuilt after a hard-over and a slam into the dirt. I had to buy a total new airframe to replace. I also have the O.S. 32 I have heard that you have to extend the engine mount slots if you use and OS.(I bought the heli used) Once I put everything back together, I lengthened the lower end of the engine mount slots to lower the engine (that is what I heard). Now the problem is that that the heli will crank and run, but I cannot get the clutch to engage on the clutch bell? I can get the top of the clutch assembly to touch the top of the cluthc bell... so that means it can get high enough; the bottom of the clutch assembly can hang below the rim of the bell by a 1/32 to 1/16.... Tell me some ideas or measurements..... I cannot get the rotors to engage not matter what height I get it....
any ideas?

PM  EMAIL  Attn:RR  Quote
04-29-2004 07:05 PM  13 years agoPost 2
HeliWhacker

rrApprentice

Childersburg, AL.

My Posts: All  Forum  Topic

I had the same thoughts as Chaos.

Clutch lining must be missing???
Did it do the funky chicken for a while, might have chewed up the lining or threw it out.

Does it try to spin the blades at all?

The starter shaft should turn freely CW when the engine is aligned.

The mount does have an up and down, you dont need to move the holes for an OS 32 to fit, whoever told you that didnt read the manual and just put the mount in upside down.

PM  EMAIL  Attn:RR  Quote
04-30-2004 03:30 AM  13 years agoPost 3
C130nut

rrNovice

Madison, Ms

My Posts: All  Forum  Topic

clutch problem

Well the clutch linig was in, but I need to verify its condition. It does seem to rotate by inertia.... one revolution per 10 to 15 secends or so. Seems like ti is rotating because of the some reason.... but no clutch contact. I will verify it tommorow.
Bill R.

PM  EMAIL  Attn:RR  Quote
04-30-2004 06:26 AM  13 years agoPost 4
B.Hofferth

rrApprentice

walkerton in.

My Posts: All  Forum  Topic

definately check the lining for glazing,wear. just had to replace the lining in both my venture 30&50 models the same day due to glazing. the lining in the 30 was wore out so bad that the clutch shoe cracked and ruined the clutch. so check your lining before its too late for the shoe.

PM  EMAIL  Attn:RR  Quote
05-02-2004 03:46 AM  13 years agoPost 5
C130nut

rrNovice

Madison, Ms

My Posts: All  Forum  Topic

problem found

Found the problem---- somehow between the time it touched the bench and the time reassembly-- the clutch bell liner came out.
Thanks guys
Bill R.

PM  EMAIL  Attn:RR  Quote
05-03-2004 04:31 AM  13 years agoPost 6
C130nut

rrNovice

Madison, Ms

My Posts: All  Forum  Topic

Well I thought the clutch bell liner was gone.... but to my surpise, it was there. It was very glazed over and a little silver... hence it looked like aluminum. After some closer looking with a flashlight.... it was there.
Now I stared looking at the gears and how things were working. I called a friend with the same model. Come to find out, I had installed the bearing in the spur gear backwards..... boy you learn something new everyday. I had no clue it was a oneway bearing... live and learn
Bill R.

PM  EMAIL  Attn:RR  Quote
WATCH
 1 page 624 views
HelicopterJR Heli Vibe 90/50, Sylphide 90, GSR260 › JR Vent. 30 Clutch problem
 Print TOPIC  Make Suggestion 

 2  Topic Subscribe

Monday, December 11 - 2:22 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online