RunRyder RC
 4  Topic Subscribe
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1312 views
HelicopterBeginners Corner › Bades flapping with idle up one switched on.
05-02-2004 06:05 PM  13 years agoPost 21
S_Owen

rrApprentice

Wichita Falls, TX.

My Posts: All  Forum  Topic

So, what did you find out? Any progress?

[b]Murphy's Constant:[/b] Matter will be damaged in direct proportion to its value.

PM  EMAIL  GALLERY  Attn:RR  Quote
05-03-2004 11:19 AM  13 years agoPost 22
rcheliheaddaz

rrApprentice

Sth Wales / UK

My Posts: All  Forum  Topic

Due to weather I have not had a chance to run it up yet and see if I have sorted it. Thanks for asking. I will let you know of any progress if any as soon as I find out.
Thanks again,
Daz

PM  EMAIL  GALLERY  Attn:RR  Quote
05-17-2004 11:19 PM  13 years agoPost 23
AMainMaker

rrKey Veteran

Nappanee,IN

My Posts: All  Forum  Topic

I have a set of quick carbon blades on my Raptor 30 and it has done the same thing but mine so violent that i had to land it. My cause was trying to run to high of a head speed . I was running around 2100 RPM head speed.I have dropped it to around 1800 now and problem is gone. I did notice and got advice from a heli rpo shop that if blades have a slight twist in them the higher head speeds will enhance this and cause one blade to go way out of track and make one heck of a problem.
Hope this helps
Jason
oh and a little more advice try being a little nicer next time. we do not know the extent of your experience will helis unlees you tell us. You say you are still somewhat of a beginner. So am I buy I will not be rude to someone for using big words just because I am upset cause I dont understand. So save your money and try lowering your headspeed a little it should help if you have the same problem I did.
Good luck and please keep the bad mouthing in other forums. Just ask FOO he knows what happens to bad mouthers

PM  EMAIL  GALLERY  Attn:RR  Quote
05-18-2004 02:36 AM  13 years agoPost 24
rcheliheaddaz

rrApprentice

Sth Wales / UK

My Posts: All  Forum  Topic

Well thanks for that, It was something that I already tried (slowing the head speed. But I am only at half throttle then) still it did seem to work. and Flew quite well. My concern is that as I am moveing to inverted flight will this reduction in head speed prevent me holding a hover inverted and then climb out. I guess I will just have to try at altitude and find out.

On the other point thanks also.

Regards
Daz.

PM  EMAIL  GALLERY  Attn:RR  Quote
05-18-2004 03:48 AM  13 years agoPost 25
AMainMaker

rrKey Veteran

Nappanee,IN

My Posts: All  Forum  Topic

No it will not effect inverted flight it will only affect flip rate. You might want to also check your thrust bearings. If your Nexus is like a raptor it will have a thrust bearing in each blade grip which I just found out today can cause the same thing.
Hope it works out for ya
Jason

PM  EMAIL  GALLERY  Attn:RR  Quote
05-18-2004 04:42 PM  13 years agoPost 26
rcheliheaddaz

rrApprentice

Sth Wales / UK

My Posts: All  Forum  Topic

Thanks for that Jason,
As it happens I did not check the thrust bearings and it turns out that that is exacly what the problem is.
Thanks very much for stearing me in that direction, Would never have looked there.
I am going to order some new now.
Thanks again.
Daz

PM  EMAIL  GALLERY  Attn:RR  Quote
05-22-2004 02:00 AM  13 years agoPost 27
rcheliheaddaz

rrApprentice

Sth Wales / UK

My Posts: All  Forum  Topic

Thrust bearings are on there way. Man I know that is it and am getting exited at the thought of going inverted for real. Not just on my simulator, I have had so much time on my sim and feel that I can manage the inverted flight fine as long as I dont get too low and cocky.

Will let you guys know how I get on, Thanks again to all of you,
And for the record, "I appologise for being an ass in the beginning"

Thanks all.
regards,
Daz

PM  EMAIL  GALLERY  Attn:RR  Quote
05-26-2004 12:37 AM  13 years agoPost 28
rcheliheaddaz

rrApprentice

Sth Wales / UK

My Posts: All  Forum  Topic

Damn Damn and Damn

Ok guys here it is, Thrust bearings arrived today and Guess what it wasn't them that was the problem
I did find out what it was though. I went into idle up 1 again and bang the violent flutter was back only this time the heli was on the deck and the cause did not hide itself.

Guys it was the servo horn slipping under preasure on the aileron servo only this time it stayed at its slip point I hit throttle cut and the swash was tilting right over even though the stick was centre. fortunatly I have a spare or 2 and put one in. problem sorted. Idle up 2 and no flutter

The servo horn was not loose but if you put some preasure on it it would slip, I guess as it fluttered it would unluckily for me settle into place. hence I couldn't see the cause till today.

Theres one to put in the flight log as a fault,action and cause so if I come accross it again I will have a chance of finding it.

Hope this Helps with educating you as it has me.
I am going to get some ali servo horns these plastic ones are just not strong enough.

Cheers guys happy flying.

Daz

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 2 pages [ <<    <     1     ( 2 )    >    >> ] 1312 views
HelicopterBeginners Corner › Bades flapping with idle up one switched on.
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Monday, December 11 - 2:57 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online