RunRyder RC
 4  Topic Subscribe
WATCH
 1 page 479 views
HelicopterMain Discussion › Loss of RPM
04-28-2004 03:12 AM  13 years agoPost 1
zsnugz

rrNovice

Roseburg, Oregon

My Posts: All  Forum  Topic

I am flying a Raptor 60V2 with a OS 61 and GV1 and am doing loops and rolls. The other day a friend had a tach and noticed when I roll the heli it loses about 150 rpm. It doesn't do this in the loop or flips. It runs fine the rest of the time. Any thoughts on what might cause this. Any ideas welcome.

Thanks,
Mike

PM  EMAIL  GALLERY  Attn:RR  Quote
04-28-2004 03:15 AM  13 years agoPost 2
ReadyHeli

rrVeteran

Jupiter, FL

My Posts: All  Forum  Topic

usually when you lower the throttle it causes this effect...

j/k

PM  EMAIL  Attn:RR  Quote
04-28-2004 03:17 AM  13 years agoPost 3
zsnugz

rrNovice

Roseburg, Oregon

My Posts: All  Forum  Topic

The GV1 is set to 1650 and stays that way always except during the rolls, should it still lose that many rpm.

PM  EMAIL  GALLERY  Attn:RR  Quote
04-28-2004 04:33 AM  13 years agoPost 4
rcnuts

rrVeteran

Millersville, Penna

My Posts: All  Forum  Topic

1650 is on the low side dude, try bumping the R's to 1800. The motor probably cant keep up when it gets loaded suddenly. Im running a GV-1 on my X-Spec. Started at 1700, went to 1800, man what a differance in performance!
Harris,

Hooligan, at large

PM  EMAIL  GALLERY  Attn:RR  Quote
04-28-2004 05:16 AM  13 years agoPost 5
Greg Faust

rrApprentice

Northern VA, USA

My Posts: All  Forum  Topic

make sure your clunk line is working properly, if it's curled to one side or the other the engine could run lean when the tanks is sideways. THIS COULD BE VERY BAD.

<<<Lithium Field Rep>>>

PM  EMAIL  HOMEPAGE  Attn:RR  Quote
04-28-2004 07:26 AM  13 years agoPost 6
sharam

rrElite Veteran

Northern California - Fly at Morgan Hill Field

My Posts: All  Forum  Topic

Check to see if you have more degrees of deflection in a roll funciton vs the pitch function.

It could that you have too much in the roll function and you are pushing the swash too far causing it to bind.

PM  EMAIL  GALLERY  Attn:RR  Quote
04-28-2004 12:22 PM  13 years agoPost 7
zsnugz

rrNovice

Roseburg, Oregon

My Posts: All  Forum  Topic

Thanks guys, all good ideas I will be checking and see what is what.
Mike

PM  EMAIL  GALLERY  Attn:RR  Quote
04-28-2004 12:29 PM  13 years agoPost 8
Sealerman

rrVeteran

Long Island, New York.

My Posts: All  Forum  Topic

The GV1 is set to 1650
Why so low? At that RPM you are lossing rotor momentum quicker than the engine can get power to it with the heavy load of a roll, I guess.
Sealerman

PM  EMAIL  GALLERY  Attn:RR  Quote
WATCH
 1 page 479 views
HelicopterMain Discussion › Loss of RPM
 Print TOPIC  Make Suggestion 

 4  Topic Subscribe

Tuesday, December 12 - 6:37 am - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies

Login Here
 New Subscriptions 
 Buddies Online