RunRyder RC Community and Forums
›› Helicopter
››› Main Discussion (
›››› Spartan Vortex VX1n Governor helpx (
Posted by Ladymagic on 06-20-2015 04:59 PM:
Okay, so I just upgraded my trusty Trex700 Nitro Pro from FB to FBL and I'm now using DMSS xBus converted from DSM2. I am running the Vortex VX1n unit due to how much like it on my Forza700E.

Anyways, I am having some issues getting the built in gov to work. In fact, I'm not even sure it is working at all. ( the Vortex and the Spartan RPM Sensor are brand new.) When I spool up, it really feels like the heli is running off of the throttle curves and not the governor. It might be the RPM sensor, but other gov units have a test phase to verify the sensor is working properly...apparently, the Vortex does not. I can't seem to find any help for the gov setup online. Bert glances over it very quickly in his videos and the Spartan page doesn't say much setups are usually very simple, but this one has been kicking my butt for a couple of weeks now. I am missing something?

Here are my questions:

1. Is there a test screen for the RPM sensor so I can rule it out as the problem?

2. Where does the Vortex Gov "lock-in" and can I change it in data pod? (Other unit such as the TJ-Pro kick in at around 25% stick.) The vortex never felt like it locked into any head speed on my test flights.

3. I broke a couple of teeth off of my stock front TT gear on my last test flight and could only find a M1 replacement set which is completely different. I ended up having to replace all of the drive train gears to match.

The main gear went from 164T to 115T, the pinion gear went from 20T to 14T, the auto rotation tail gear went from 150T to 104T. My old ratio was 8.2:1:4.54 (E:M:T). Anyone know the new ratio? I know the formula but, I'm too lazy to do the math

4. Can I use an external gov with the Vortex when connected via xbus? I thought I could because I have my ESC throttle running through the main rx so I can use the ESC gov with no problems on my Forza700. It is running the same rx setup as the Trex700. Since I can't confirm that the Vortex gov is working, I decided to reinstall my original gov the similar on the Forza, but there is no signal or power to the throttle servo when plugged directly to the rx, but it is giving power when I connect an old TJ Revmax to the same channel....even then, power is only passed through the Revmax (the SET and SENS lights illuminate), but still nothing to the servo when I plug it into the Revmax. What's even more weird is I'm trying to use an Align gov that I just flew before this upgrade. It get does not seem to get any power when I plug it in the same way.

I am running the XG14. Xbus, mode B. I have the Gov channel set to active and linked to my flight mode switch.

I double checked all the pins, the throttle servo is good. What am I missing here? If it sounds probably isn't. I just have a lot of options going through my head and probably relating well in this post. So, just ask and I'll try and explain it better for you.

I'm hoping someone else has already solved this issue and can help.


Posted by barely can fly on 06-21-2015 01:41 PM:
just divide 115 by 14 and you get 8.21, gear ratio still the same.
Set up a vx1n gov. in my t-rex 600n but don't remember how it went but don't remember being hard at all,
I will look at it with the datapod and see if I can remember and explain it.

ATLRC wrecking crew / NCRC

Posted by Cromer on 06-21-2015 03:38 PM:
On the main screen of the datapod there will be a light that says Sen that will come on when the magnet is under the sensor if everything is working ok. It will go out as the magnet moves away from the sensor so you have to keep an eye out for it. If that is not working I would check to make sure the gap between the sensor and the magnet is not too large or that the magnet has not been put in backwards. If all of that is working ok it means that the Vortex is seeing the magnet ok and your problem is elsewhere. I am trying to setup my gov on a Gaui NX7 and am still learning as I go. It seems from my research that the gov gain can play a big part in getting it to work well as can your throttle curves. Hopefully someone who has a bit more experience will chime in to help us out.


Posted by Cromer on 06-21-2015 04:00 PM:
To elaborate on my first post you also have to have the gov turned on in the flight modes you want it to work in. You can verify this on the main screen also because it will show your desired rpm in a box on the right and as you raise your throttle when you get to 25% two lights will light that say STK and GOV. That also answers your other question about when the Vortex gov kicks in, it is at 25%.


Posted by Cromer on 06-21-2015 05:14 PM:
The on-off spot can be changed via an advanced setting in the gov menu if you would like. It also states that the gov will come on at anything over the set point and turn off at 5% below the set point. If you have it set at 25% it will come on at anything over 25% and shut off at anything under 15%.


Posted by goof2 on 06-22-2015 05:22 PM:
Is your flight modes setup in the vortex? Can you verify them changing with the transmitter? What firmware version are you using? Are you using the data pod or pc?
Posted by Ladymagic on 06-23-2015 03:29 PM:
Yes, I have all the flight modes setup through the vortex and linked to my flight mode switch. I haven't flight tested it, but I was able to confirm that the sensor is working. I made some minor tweeks and adjusted the gain. Hopefully, I can get it to work.=) I should be able to run it today and I will let you know how it goes.


Posted by Ladymagic on 09-20-2015 06:41 PM:
Governor issue resolved
Turns out the governor problems I was having were self induced. The governor was actually working the first time. I had just installed a new FBL head on my Trex700N FB heli so the issue was the swash wasn't set correctly at zero degrees at mid was actually set at -2 degrees at mid stick (I just eyeballed it). So basically, when the engine seemed like it was overspending when the gov engaged, it was just due to the fact that there wasn't a load on the head. Readjusted the swash height and we're good to go now. Been flying great for over a month now.

Oh well...lesson learned...thanks for all the help guys...


Mon, Jun 25 - 5:02 pm © 2000-2018 RunRyder