RunRyder RC
 2  Topic Subscribe
WATCH  1 page 110 views POST REPLY
ProModeler Scorpion Power
andrehuttener

New Heliman

Brazil

My Posts: All  Forum  Topic

Hi!

I have a second hand TREX600 with Futaba GY611 gyro. My helicopter gyro functions perform flawlessly. However, I noticed my amplifier screen has black blocks from left to right. Changing values from the radio does not do a thing to the screen. Anyone know what this may have been from, and what do I need to do to remedy this problem.
I try to adjust contrast, but without result...

[img]http://www.rcuniverse.com/forum/attachment.php?attachmentid=2193778&d=1482087765[/img]

Thank you,

Andre.

12-18-2016 07:14 PM
PM  EMAIL  Attn:RR
fastrc1

Key Veteran

Brooklyn, NY-USA

My Posts: All  Forum  Topic

I'm going to assume that the contrast pot may be bad. Try to get in contact with the Futaba Brazilian distributor and see what they can do.

Eaton

RIP Roman Pirozek Jr.
Team SRW Comp
Zeal Blades U.S. Flight Team
HRP
Citizen #664
Team Venom Power
Team CanoMod

12-18-2016 10:11 PM
PM  EMAIL  GALLERY  Attn:RR
Dr.Ben

rrMaster

Richmond, VA, USA

My Posts: All  Forum  Topic

Service is not financially practical. If you post here on RR, I bet you can find a used gy611 for barely the cost of shipping.

Ben Minor

Team Synergy Team Futaba Team Kontronik USA
Progressive RC

12-19-2016 04:16 AM
PM  EMAIL  GALLERY  Attn:RR
WATCH  1 page 110 views POST REPLY
ProModeler Scorpion Power
 Print TOPIC Advertisers 

 2  Topic Subscribe

Friday, January 20 - 6:04 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies