RunRyder RC
 2  Topic Subscribe
WATCH  1 page 95 views POST REPLY
ProModeler Scorpion Power
R38133

Key Veteran

USA

My Posts: All  Forum  Topic

Got this ESC used no manual installed a BEC put in heli attached motor plugged in 4S battery ESC just flashes tryed 3S battery still flash o I had also removed the red [pos] center wire on the ESC Was this my error????PS I dont have a castle link tryed to find manual no luck castle web site will not open my ESC
any help would be appreciated

11-20-2016 01:23 AM
PM  EMAIL  GALLERY  Attn:RR
Slowpoke

Key Veteran

Dublin, OH

My Posts: All  Forum  Topic

You should not remove the red wire.

Castle's web site has all the documentation and wiring guides for the Phoenix Edge HV 40. Should be the same.

There is a guide showing the led flash codes to give you an idea where the problem lies.

Make sure your throttle stick is at zero, your throttle curve low end is at zero, and the endpoint on your throttle channel is at zero. If not, this could prevent the esc from arming.

11-20-2016 03:43 AM
PM  EMAIL  GALLERY  Attn:RR
Slowpoke

Key Veteran

Dublin, OH

My Posts: All  Forum  Topic

11-20-2016 03:45 AM
PM  EMAIL  GALLERY  Attn:RR
R38133

Key Veteran

USA

My Posts: All  Forum  Topic

Thanks Slowpoke I got it for sime reason I could not see manual on website all is good now

11-20-2016 02:48 PM
PM  EMAIL  GALLERY  Attn:RR
WATCH  1 page 95 views POST REPLY
ProModeler Scorpion Power
 Print TOPIC Advertisers 

 2  Topic Subscribe

Monday, January 23 - 4:55 pm - Copyright © 2000-2017 RunRyder   EMAILEnable Cookies