RunRyder RC
 4  Topic Subscribe
WATCH  2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 647 views TOPIC CLOSED
Scorpion Power AlignRC
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

Hello guys I am looking for help I have a tail twitch not a wag

When in a hoover the heli has a twitch in the tail I tried it with the gov on and off its still there I tried turning the gain up and down on the controller and its still there its like when a nitro is four stroking and the tail twitches that is the best I can describe it.

This is the set up a Fusion 50 CC 100amp ice esc Align RCM BL 600mx with a 12T pion and Brand new RC OMG servos.

Thanks for any help

10-15-2016 01:33 PM
PM  EMAIL  GALLERY  Attn:RR
JuanRodriguez

Elite Veteran

The Villages, Florida

My Posts: All  Forum  Topic

Try placing the heli on the ground rather than on a vacuum cleaner.....LOL ! Just kidding !!!

Check the mounting on your controller.... a worn mounting pad can give you issues....

Been there, done that and old enough to know better.....

10-15-2016 01:43 PM
PM  EMAIL  GALLERY  Attn:RR
crflyer

Senior Heliman

Maine

My Posts: All  Forum  Topic

I had a similar issue and it turned out to be bad tail grip thrust beaings.

10-15-2016 01:47 PM
PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

I just put this controller on it so it has new tape and the controller is new also

10-15-2016 01:48 PM
PM  EMAIL  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

crflyer I will check that now

10-15-2016 01:50 PM
PM  EMAIL  GALLERY  Attn:RR
JuanRodriguez

Elite Veteran

The Villages, Florida

My Posts: All  Forum  Topic

Also, disconnect the link at the tail rotor servo and mechanically ensure that the push rod moves silky smooth throughout its range of travel.... a sticky rod along one of the boom guides can cause trouble....

Been there, done that and old enough to know better.....

10-15-2016 01:54 PM
PM  EMAIL  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

I will also check that out to thanks

10-15-2016 01:59 PM
PM  EMAIL  GALLERY  Attn:RR
artimus

Key Veteran

Buckley WA

My Posts: All  Forum  Topic

I had areally anoying twitch also on a cc Talon 90. I had heard about the castel creations twitch here on RR.Seemd to be related to the gov . i tried different gain settings on the gov. Gov on gov off didnt matter...still twiched. Thought i would change the esc to a Hobbywing 100 and the twich went away.
Thats what it took for me .

Fly Hard......Team Viagra

10-15-2016 05:01 PM
PM  EMAIL  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

Oh I hope it's not the esc

10-15-2016 05:53 PM
PM  EMAIL  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

Well still there it just won't go away

10-15-2016 06:46 PM
PM  EMAIL  GALLERY  Attn:RR
RappyTappy

rrProfessor

North Denver, Colorado

My Posts: All  Forum  Topic

Whats your gyro? Tail servo? Gyro tail setting? Ever crashed the gyro/is this a rebuild? Got the right servo speed selected if need be? Tail shaft not binding on slider? Tail action smooth? Thrust bearings on tail, if equipped, correctly installed and lubed? Tail balanced? No excessive vibes in the heli? ....I could go on about how many things could cause this, as many simple things could affect this.

I use a process of elimination as my method and either change things to test (like gyro tape, tail servo ect) or check the heli mechanically and even check the internals of the electonics.

I had a mystery tail twich on a JR gyro a long time ago. Tried everything I thought of at that time and couldnt figure it out. Sold it for cheap to a local guy and told him I just bought a new gyro and what the issue was with it. Well, he opened it up (as I should have, doh!) and found the wires chafing on the metal case inside the gyro itself causing all of the problems.

Take some bench time and go over the basics.

10-15-2016 11:31 PM
PM  EMAIL  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

I think its in the esc or motor its like its four stroking and kicking the tail

10-15-2016 11:37 PM
PM  EMAIL  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

I think I might have gotten it I put it back in gov mode and turned the gain to 10

TH curve N 0 30-------30 2000 head speed
up 1 70-------70 2100 head speed
up 2 100------100

10-16-2016 02:15 PM
PM  EMAIL  GALLERY  Attn:RR
don s

Key Veteran

Chesapeake, VA

My Posts: All  Forum  Topic

O, you said controller gain in the first post. I misread as governor gain, otherwise I would have mentioned that. I've had the same problem in the past.

E820, Raptor G4N, X50F/E, E620, Forza 450, and some planks.

10-16-2016 03:07 PM
PM  EMAIL  GALLERY  Attn:RR
RappyTappy

rrProfessor

North Denver, Colorado

My Posts: All  Forum  Topic

Governor gain wont have much effect since you said you turned the governor off and it still has a kicking tail. Ive never seen a electric motor four stroke, maybe it needs some new muffler bearings

I checked in your gallery since you didnt post what gyro you have and see a yellow unit, looks like a vbar clone or something?

10-16-2016 03:22 PM
PM  EMAIL  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

yes the gov gain on the esc and yes a vbar clone

I did the controller gain also but with no effects it was still there and just reset the gov back up with 10 on the gain and most of the kick is gone still has a little

now I am trying to figure out the gear ratio with a 129 main gear and 12 pinon and the proper hrz on the motor and I think its a 6 pole motor

10-16-2016 03:29 PM
PM  EMAIL  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

What I meant by four stroking you could hear the motor cutting in and out and the tail was kicking

10-16-2016 03:39 PM
PM  EMAIL  GALLERY  Attn:RR
don s

Key Veteran

Chesapeake, VA

My Posts: All  Forum  Topic

Maybe some of the ESC settings are off?

E820, Raptor G4N, X50F/E, E620, Forza 450, and some planks.

10-16-2016 07:02 PM
PM  EMAIL  GALLERY  Attn:RR
BK479

Senior Heliman

Austin IN.

My Posts: All  Forum  Topic

its a lot better now but did notice a little vibration in the skids in this last hover test it could be the blades. I did spin it around and the main shaft looks to be true according to the head button

10-16-2016 09:04 PM
PM  EMAIL  GALLERY  Attn:RR
junkpilot

Veteran

Alamogordo N.M.

My Posts: All  Forum  Topic

Tail twitching

I understand you may have fixed your problem but I want to trow out an idea that can also cause a twitch you just can't find. remove,clean and check every bearing in the driveline for both main rotor and tailrotor.
I'm sure every one of you has seen bearings with pits in the races. Well when you're trying to fly and a ball comes around and hits that pit it can instantly stop a tail rotor. I've even seen mainshafts grind to a halt just a the heli touched down.
Be sure on reassembley you lube or replace your bearings.
Happy flying! Junkpilot

When you fly JUNK it's hard to tell when you've crashed!

10-17-2016 11:11 PM
PM  EMAIL  GALLERY  Attn:RR
WATCH  2 pages [ <<    <    ( 1 )     2     NEXT    >> ] 647 views TOPIC CLOSED
Thunder Power RC ProModeler
 Print TOPIC Advertisers 

 4  Topic Subscribe

Saturday, December 3 - 9:33 am - Copyright © 2000-2016 RunRyder   EMAILEnable Cookies