RunRyder RC
 4  Topic Subscribe
WATCH  1 page 169 views POST REPLY
AlignRC Scorpion Power
Lyle Mahon

Heliman

Australia

My Posts: All  Forum  Topic

Guys and girls I am having major problems jamming my 5s 65c 5000 packs into my 600 I know I have a bit of work to do tidying up the wiring ( and the bench) I just can't see it working can you guys help me out maybe throw up a few pictures and tell me how you got around it. Will try and load photo but need to work how to do it first

Living the dream

08-10-2016 06:18 AM
PM  EMAIL  Attn:RR
DemetriusUSN

Veteran

Virginia Beach, Va USA

My Posts: All  Forum  Topic

My Logo 600se is also running on 10s and my packs are thor 5s 5000 35c I think. I will take pictures when I get home.

Minicopter Diabolo 700, Compass 7hv, Goblin 700 triblade, Compass 6hvu, Logo 600se

08-10-2016 05:05 PM
PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
gologo

Key Veteran

Sedalia, Mo USA

My Posts: All  Forum  Topic

Having trouble getting them to go in the front of the frames or under the
pinion? I also run a lot of 5s no problem, but 65c I can imagine being
much fatter/taller. If it is an issue w. going in the front, a dremel and
a few minutes will take care of that. If they are too tall to go under the
pinion and/or motor shaft.......

08-12-2016 12:20 AM
PM  EMAIL  GALLERY  Attn:RR
cudaboy_71

Elite Veteran

sacramento, ca, u.s.

My Posts: All  Forum  Topic

I ran GensAce 5300 10s for years on my SE. On those packs the cells had to be set up vertically. As they aged and started getting a little puff to them, I had to dremel out the front opening. But, that Mikado plastic dremels nicely. You couldn't even tell it has been worked on. It came out very smooth.

if it ain't broke, break it.

08-12-2016 12:23 AM
PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
WATCH  1 page 169 views POST REPLY
Thunder Power RC AlignRC
 Print TOPIC Advertisers 

 4  Topic Subscribe

Sunday, September 25 - 9:51 am - Copyright © 2000-2016 RunRyder   EMAILEnable Cookies