RunRyder RC
 2  Topic Subscribe
WATCH  1 page 137 views POST REPLY
Thunder Power RC AlignRC
Antsis

Senior Heliman

Melbourne, Victoria, Australia

My Posts: All  Forum  Topic

Hi Guys

I have a installed a miniTags with RA02 remote aerial on a 700e with Savox SV-1273TG cyclic servos and a Savox SV1274MG rudder servo. I have setup the neutral point and calibrated the cyclics/collective with no problem. My issue is that when I go to full pitch the swashplate tips backwards.

I have reloaded the firmware (ver.3.9)and checked there are no subtrims active. Any ideas? Could it be the servos?

Ant

07-24-2016 05:51 AM
PM  EMAIL  GALLERY  Attn:RR
LaDon

Veteran

Fort Dodge .Ia

My Posts: All  Forum  Topic

I have done a video on the setup of the mini tags. Here is a link. Probably what has happened is you missed a step somewhere. Like I say in the video make sure you follow the little book to the letter. Don't assume anything. I couldn't tell you right off what it is. Also does it just tilt back a little or is the elevator servo just wrong? Here is the link

Watch at YouTube

Team Jr

07-24-2016 05:06 PM
PM  EMAIL  GALLERY  Attn:RR
Antsis

Senior Heliman

Melbourne, Victoria, Australia

My Posts: All  Forum  Topic

Hi LaDon

Thanks. Great video. This is actually my 2nd minitags. My first one is on my Sylphide E12 and was straightforward. The elevator servo goes to full deflection as the pitch is increased. I will look at it again this weekend.

Ant

07-25-2016 09:14 AM
PM  EMAIL  GALLERY  Attn:RR
WATCH  1 page 137 views POST REPLY
Scorpion Power Thunder Power RC
 Print TOPIC Advertisers 

 2  Topic Subscribe

Thursday, September 29 - 12:52 am - Copyright © 2000-2016 RunRyder   EMAILEnable Cookies