RunRyder RC
 3  Topic Subscribe
WATCH  2 pages [ <<    <     1     ( 2 )    >    >> ] 813 views POST REPLY
ProModeler Scorpion Power
honda411

Key Veteran

Surprise, AZ USA

My Posts: All  Forum  Topic

So everything seems to be working good in the 500. Although it does seem like the gain is pretty low to prevent tail shake. It had a similar bad wag at one point just like the 700.
With the 700 I didn't think the gain should be as low as it was for the wag to go away. Hence why I didn't think it was a gain problem. I will be redoing head bearing and dampeners and all that to make sure.
Also on forward only elevator flips I get a cyclic/aileron shake. Not backwards though. Anyone also know what this is?

HeliDirect Field Rep, Synergy N7 w/ OS 105, Torq Servos, Cyclone/ Rail blades

07-14-2016 01:43 AM
PM  EMAIL  GALLERY  Attn:RR
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

How are you determining that the tail gain is low? You can't go by the numbers in your tx.

Not sure about the aileron shake during only forward flips. Is the BeastX mounted perfectly squarely? What blades are you using? Have you increased pot 2 on the BeastX at all?

60% of the time, it works every time!

07-14-2016 06:56 AM
PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
don s

Key Veteran

Chesapeake, VA

My Posts: All  Forum  Topic

The manual leads me to believe that just the HD version is rated to 8.4V. Maybe it's just poorly written?

E820, Raptor G4N, X50F/E, E620, Forza 450, and some planks.

07-14-2016 02:43 PM
PM  EMAIL  GALLERY  Attn:RR
honda411

Key Veteran

Surprise, AZ USA

My Posts: All  Forum  Topic

The lights on the unit itself just seem low. But it's probably okay. But it is mounted squarely. I have not touched pot 2 yet. I am a bit confused on the pots but I'll re read the manual. For now I'm using torsion blades to start with on the 500 just in case something happens I don't damage my edge blades

I will probably get an hv regulator of some sort to conquer the issue hopefully

HeliDirect Field Rep, Synergy N7 w/ OS 105, Torq Servos, Cyclone/ Rail blades

07-14-2016 03:17 PM
PM  EMAIL  GALLERY  Attn:RR
Richardmid1

rrProfessor

Leeds, England

My Posts: All  Forum  Topic

You can't judge the gain by the lights on the unit either. Are the torsion blades FBL blades?

60% of the time, it works every time!

07-14-2016 04:08 PM
PM  EMAIL  HOMEPAGE  GALLERY  Attn:RR
icanfly

Elite Veteran

ontario

My Posts: All  Forum  Topic

make sure all the pots are set to center, a tiny tweek of those in either direction can add or subtract marginally to existing programmed gains

07-14-2016 11:14 PM
PM  EMAIL  GALLERY  Attn:RR
honda411

Key Veteran

Surprise, AZ USA

My Posts: All  Forum  Topic

Richard I'm not entirely sure since they came with the heli. But I am going to try the edge blades now. I'm sure they are way better. Pots 2&3 are centered and pot 1 is just a hair above center. I lowered the gain to E on the unit and 27% in the radio. It helped.

HeliDirect Field Rep, Synergy N7 w/ OS 105, Torq Servos, Cyclone/ Rail blades

07-15-2016 02:50 AM
PM  EMAIL  GALLERY  Attn:RR
WATCH  2 pages [ <<    <     1     ( 2 )    >    >> ] 813 views POST REPLY
AlignRC Thunder Power RC
 Print TOPIC Advertisers 

 3  Topic Subscribe

Saturday, December 10 - 6:49 am - Copyright © 2000-2016 RunRyder   EMAILEnable Cookies