RunRyder RC
 3  Topic Subscribe
WATCH  1 page 382 views POST REPLY
Scorpion Power AlignRC
flyin dan

Senior Heliman

Beloit Wi.

My Posts: All  Forum  Topic

Hi all, I have been using a 520 for a few years now in two different models, one of which has developed a slight drift to the left. No matter what i have tried the nose will drift in a hover, or forward flight. Two different radios, 8FG, 14SG, no sub trim, or trim on the tail. I have the same setup in a diff. heli, flys fine.
This gyro was in a crash two years back, bad auto. Is this how the 520 acts when they finally go bad?? Is it possible to send these in for repair? Vibes are low, no runout on fan, tailrotor shaft or mainshaft, blades balanced well. S9254 servo, engine runs fine, smooth control movment to tail control.

AMA # 943111

07-07-2016 07:47 PM
PM  EMAIL  GALLERY  Attn:RR
fastrc1

Key Veteran

Brooklyn, NY-USA

My Posts: All  Forum  Topic

Did you try changing the servo?

RIP Roman Pirozek Jr.
Team SRW Comp
Zeal Blades U.S. Flight Team
HRP
Citizen #664
Team Venom Power
Team CanoMod

07-07-2016 09:29 PM
PM  EMAIL  GALLERY  Attn:RR
flyin dan

Senior Heliman

Beloit Wi.

My Posts: All  Forum  Topic

Haven't tried that yet, servo seems ok, no noise or roughness.
I will hover in rate mode pretty well hands off. The 14Sg has Gyro sub trim, what is that for exactly?

AMA # 943111

07-07-2016 09:47 PM
PM  EMAIL  GALLERY  Attn:RR
fastrc1

Key Veteran

Brooklyn, NY-USA

My Posts: All  Forum  Topic

Hmm. I've never used it. Maybe the Good Dr. Ben can chime in. Also is your rudder trim @ neutral?

RIP Roman Pirozek Jr.
Team SRW Comp
Zeal Blades U.S. Flight Team
HRP
Citizen #664
Team Venom Power
Team CanoMod

07-07-2016 10:47 PM
PM  EMAIL  GALLERY  Attn:RR
Josh Kussman

Senior Heliman

Superior, NE

My Posts: All  Forum  Topic

If u haven't already you may want to check the tape that you are using to mount the gyro to Heli. Sometimes it'll yet the gyro move with small amounts of vibrations if it's old. Would check that and radio setting trims and travels.

07-07-2016 11:22 PM
PM  EMAIL  GALLERY  Attn:RR
Dr.Ben

rrMaster

Richmond, VA, USA

My Posts: All  Forum  Topic

It's not the servo.

1. Make sure the tail is trimmed mechanically before entering AVCS.

2. Try mounting the sensor on at least 3mm of Futaba gyro tape or 2mm tape - metal plate- 2mm of tape. Zeal gel also works well. Playing with tape is especially important on a nitro model with drift even if the model seems smooth. The GY520 has such low mass that it actually has trouble dealing with vibration in some cases. And before someone chimes in about this comment, the GY750 also has low mass but uses a vastly different kind of sensor.

3. Rotate the sensor 45d to its current mounting orientation and remount. Yes, this can affect drift.

4. If the drift persists and your radio allows you to separate your rudder trims, you can boot radio up in a flight condition such as throttle hold with zero trim, and then trim the drift out as needed in the other flight conditions. Contrary to common belief, you may trim an AVCS gyro flight as long as the gyro is always booted up in a flight condition with zero trim.

5. If needed, I have a 520 which could be had for peanuts.

Ben Minor

Team Synergy Team Futaba Team Kontronik USA
Progressive RC

07-08-2016 04:45 AM
PM  EMAIL  GALLERY  Attn:RR
flyin dan

Senior Heliman

Beloit Wi.

My Posts: All  Forum  Topic

Right now the its mounted with the foam pad, plate, double sided mounting tape between the plate and gyro. Ill try rotating it and remounting. Need to order more foam mounting pads!
Will try tomorrow, after helping out with installing a new fabric
runway at our field.
By the way, where do you buy Zeal gel?

AMA # 943111

07-09-2016 01:39 AM
PM  EMAIL  GALLERY  Attn:RR
don s

Key Veteran

Chesapeake, VA

My Posts: All  Forum  Topic

https://www.google.com/search?q=kyo...=utf-8&oe=utf-8

Some purchasing options.

E820, Raptor G4N, X50F/E, E620, Forza 450, and some planks.

07-09-2016 05:11 AM
PM  EMAIL  GALLERY  Attn:RR
flyin dan

Senior Heliman

Beloit Wi.

My Posts: All  Forum  Topic

Tried today with the gyro mounted 90 deg from where it was, no real difference. will order the zeal tape and try that.

AMA # 943111

07-09-2016 07:39 PM
PM  EMAIL  GALLERY  Attn:RR
Four Stroker

Elite Veteran

Atlanta

My Posts: All  Forum  Topic

Not to beat a dead horse but are you sure that you did not accidentally turn on the tail mixing ? Rudder compensation or whatever the 14SG call it.

07-09-2016 11:55 PM
PM  EMAIL  GALLERY  Attn:RR
flyin dan

Senior Heliman

Beloit Wi.

My Posts: All  Forum  Topic

Nope, no rudder comp active.

AMA # 943111

07-10-2016 02:01 AM
PM  EMAIL  GALLERY  Attn:RR
Josh Kussman

Senior Heliman

Superior, NE

My Posts: All  Forum  Topic

Have you ever replaced the bearings in heli? i would check them before changing out any ectronics.

07-10-2016 12:06 PM
PM  EMAIL  GALLERY  Attn:RR
flyin dan

Senior Heliman

Beloit Wi.

My Posts: All  Forum  Topic

I redid this machine about 4 years back, might be a bad bearing.
Thinking of pulling the engine to change out the fan for one with a magnet, good time to look at bearings.

AMA # 943111

07-10-2016 02:17 PM
PM  EMAIL  GALLERY  Attn:RR
flyin dan

Senior Heliman

Beloit Wi.

My Posts: All  Forum  Topic

May have the problem identified, booted up the CIU to the computer
and seen that Rudd was channel 1 and Gain was 4! I have been flying this for A WHILE like this...... I have redone the end points a few times now, never noticed it! WOW.

AMA # 943111

07-11-2016 12:01 AM
PM  EMAIL  GALLERY  Attn:RR
Four Stroker

Elite Veteran

Atlanta

My Posts: All  Forum  Topic

LMAOROF, All of these drifting stories are finally revealed to be improper programming.

07-15-2016 01:44 PM
PM  EMAIL  GALLERY  Attn:RR
flyin dan

Senior Heliman

Beloit Wi.

My Posts: All  Forum  Topic

That was the problem! Flys great now. Thanks for the suggestions guys.

AMA # 943111

07-17-2016 01:28 PM
PM  EMAIL  GALLERY  Attn:RR
Four Stroker

Elite Veteran

Atlanta

My Posts: All  Forum  Topic

We are glad you fixed it.

07-18-2016 02:17 AM
PM  EMAIL  GALLERY  Attn:RR
RAK402

Elite Veteran

Alhambra, CA

My Posts: All  Forum  Topic

Glad you got it fixed!

I had 11 of these in service at one time and really liked them.

Team KBDD/Compass Team Manger/Prostar Hobby/Team JR Americas/Gens Ace/WR Field Rep

07-19-2016 11:53 PM
PM  EMAIL  GALLERY  Attn:RR
flyin dan

Senior Heliman

Beloit Wi.

My Posts: All  Forum  Topic

Mine work really well when programmed correctly!

AMA # 943111

07-20-2016 01:15 AM
PM  EMAIL  GALLERY  Attn:RR
WATCH  1 page 382 views POST REPLY
Thunder Power RC ProModeler
 Print TOPIC Advertisers 

 3  Topic Subscribe

Sunday, December 11 - 12:15 am - Copyright © 2000-2016 RunRyder   EMAILEnable Cookies